Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1144492

Summary: Unable to import BRMS 6.0.2, Error: The original product type discovered for this server was EAP, but the server is now reporting its product type is [BRMS]
Product: [JBoss] JBoss Operations Network Reporter: Jeeva Kandasamy <jkandasa>
Component: Plugin -- BRMS 5Assignee: Libor Zoubek <lzoubek>
Status: CLOSED DUPLICATE QA Contact: Mike Foley <mfoley>
Severity: high Docs Contact:
Priority: unspecified    
Version: JON 3.3.0CC: hrupp, myarboro, theute
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-25 15:54:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
agent.log none

Description Jeeva Kandasamy 2014-09-19 14:21:18 UTC
Created attachment 939362 [details]
agent.log

Description of problem:
Unable to import BRMS product in to JBoss ON.

It says,

2014-09-19 07:05:08,918 WARN  [InventoryManager.availability-1] (rhq.core.pc.inventory.AvailabilityExecutor)- Availability collection failed with exception on Resource[id=10141, uuid=fa39f7fb-72c5-4965-94e2-defbecd12fe4, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /home/hudson/jboss-eap-6.1/standalone/configuration/standalone.xml, name=EAP (127.0.0.1:9990), parent=jeeva-ha3-jxc.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.1.1.GA], availability will be reported as DOWN, reason=Failed to start component for Resource[id=10141, uuid=fa39f7fb-72c5-4965-94e2-defbecd12fe4, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /home/hudson/jboss-eap-6.1/standalone/configuration/standalone.xml, name=EAP (127.0.0.1:9990), parent=jeeva-ha3-jxc.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.1.1.GA] - The original product type discovered for this server was EAP, but the server is now reporting its product type is [BRMS]

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.ER03
Build Number : 4aefe39:44e33a4
GWT Version : 2.5.0
SmartGWT Version : 3.0p

BRMS:
[hudson@jeeva-ha3-jxc ~]$ java -jar jboss-brms-installer-6.0.2.GA-redhat-5.jar -version
Product: Red Hat JBoss BRMS Installer
Version: 6.0.2


How reproducible:
always

Steps to Reproduce:
1. Install 'jboss-brms-installer-6.0.2.GA-redhat-5.jar'
2. Follow installation steps from https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BRMS/6.0/pdf/Installation_Guide/Red_Hat_JBoss_BRMS-6.0-Installation_Guide-en-US.pdf
3. Section: 2.6. Installing Red Hat JBoss BRMS using the Installer in CLI Mode
4. Start BRMS server (./standalone.sh)
5. It will be available in Discovery queue in the name of 'EAP(127.0.0.1:9990)'
6. Imported the resource(from Step #5)
7. After import, update the authentication details under 'Inventory->Connection Setting' of the imported resource.
8. Once updated the connection settings, agent starts reporting in agent.log file as,

2014-09-19 07:04:24,383 INFO  [WorkerThread#0[10.16.23.184:36022]] (rhq.core.pc.inventory.InventoryManager)- Unable to connect to managed resource of type [JBossAS7 Standalone Server] using the specified connection properties.
org.rhq.core.pluginapi.inventory.InvalidPluginConfigurationException: Failed to start component for Resource[id=10141, uuid=fa39f7fb-72c5-4965-94e2-defbecd12fe4, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /home/hudson/jboss-eap-6.1/standalone/configuration/standalone.xml, name=EAP (127.0.0.1:9990), parent=jeeva-ha3-jxc.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.1.1.GA] - The original product type discovered for this server was EAP, but the server is now reporting its product type is [BRMS]



Additional info: agent.log is attached.

Comment 2 Heiko W. Rupp 2014-09-25 15:39:45 UTC
Libor, as you already looked into Bug 1144489, which is similar / the same, can you please look at this one as well?

Comment 3 Libor Zoubek 2014-09-25 15:54:18 UTC

*** This bug has been marked as a duplicate of bug 1144489 ***