Bug 1144489 - [BRMS 6] The original product type discovered for this server was EAP, but the server is now reporting its product type is [BRMS]
Summary: [BRMS 6] The original product type discovered for this server was EAP, but th...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ER04
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Tomas Schlosser
URL:
Whiteboard:
Keywords:
: 1144492 (view as bug list)
Depends On:
Blocks: 1168373 JON3-12
TreeView+ depends on / blocked
 
Reported: 2014-09-19 14:10 UTC by Libor Zoubek
Modified: 2015-11-02 00:44 UTC (History)
6 users (show)

(edit)
Clone Of:
: 1168373 (view as bug list)
(edit)
Last Closed: 2014-12-11 14:04:20 UTC


Attachments (Terms of Use)
jboss-brms (113.07 KB, image/jpeg)
2014-10-09 09:01 UTC, Jeeva Kandasamy
no flags Details

Description Libor Zoubek 2014-09-19 14:10:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. install BRMS 6
2. import it and set credentials

Actual results: plugin is unable to manage BRMS (Server seems DOWN reporting invalid plugin configuration), in agent logs there are: 

2014-09-19 16:08:05,884 WARN  [InventoryManager.availability-1] (rhq.core.pc.inventory.AvailabilityExecutor)- Availability collection failed with exception on Resource[id=10004, uuid=b56243da-cee2-4b85-b672-0f5c62f1ad30, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /data/jboss/brms/jboss-eap-6.1/standalone/configuration/standalone.xml, name=EAP (127.0.0.1:9990), parent=localhost.localdomain, version=EAP 6.1.1.GA], availability will be reported as DOWN, reason=Failed to start component for Resource[id=10004, uuid=b56243da-cee2-4b85-b672-0f5c62f1ad30, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /data/jboss/brms/jboss-eap-6.1/standalone/configuration/standalone.xml, name=EAP (127.0.0.1:9990), parent=localhost.localdomain, version=EAP 6.1.1.GA] - The original product type discovered for this server was EAP, but the server is now reporting its product type is [BRMS]


Expected results: BRMS resource becomes UP and managable


Additional info:

Comment 1 Larry O'Leary 2014-09-23 15:18:23 UTC
This appears to be a bug in the JBoss EAP 6 plug-in as BRMS/BPMS does not extend the AS plug-ins.

Comment 2 Libor Zoubek 2014-09-25 13:23:23 UTC
I've set the component to BRMS 5, because there's nothing for BRMS 6 plugin.

But you're right, it's AS7 plugin issue.

Comment 3 Libor Zoubek 2014-09-25 15:21:30 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/d6f0bcbad
time:    2014-09-25 17:21:07 +0200
commit:  d6f0bcbad0b47af065035ed62f50b44071c9dc81
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1144489 - [BRMS 6] The original product type discovered for this
         server was EAP, but the server is now reporting its product
         type is [BRMS]
         Adding BRMS into set of known AS7 based products

Comment 4 Libor Zoubek 2014-09-25 15:54:18 UTC
*** Bug 1144492 has been marked as a duplicate of this bug. ***

Comment 5 Jirka Kremser 2014-09-26 13:29:05 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/daabd1589
time:    2014-09-26 15:28:02 +0200
commit:  daabd1589419b55291e15c3986e9352814b73808
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1144489 - [BRMS 6] The original product type discovered for this
         server was EAP, but the server is now reporting its product
         type is [BRMS]

         Adding BRMS into set of known AS7 based products

         (cherry picked from commit
         d6f0bcbad0b47af065035ed62f50b44071c9dc81) Signed-off-by: Jirka
         Kremser <jkremser@redhat.com>

Comment 6 Simeon Pinder 2014-10-01 21:33:12 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 7 Jeeva Kandasamy 2014-10-09 09:01:25 UTC
Created attachment 945238 [details]
jboss-brms

Imported successfully. Also available in CSP. Verified screen shot is attached

Version: 
JBoss Operations Network
Version : 3.3.0.ER04
Build Number : 99d2107:d7c537e
GWT Version : 2.5.0
SmartGWT Version : 3.0p


Note You need to log in before you can comment on or make changes to this bug.