Bug 114475 - Files and directories not owned by mozilla package
Files and directories not owned by mozilla package
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 10:44 EST by W. Michael Petullo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 18:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-01-28 10:44:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
The following files and directories are not owned by the mozilla 1.6-0
RPM:

/usr/lib/mozilla-1.6/chrome/chrome.rdf
/usr/lib/mozilla-1.6/chrome/overlayinfo
/usr/lib/mozilla-1.6/chrome/overlayinfo/communicator
/usr/lib/mozilla-1.6/chrome/overlayinfo/communicator/content
/usr/lib/mozilla-1.6/chrome/overlayinfo/communicator/content/overlays.rdf
/usr/lib/mozilla-1.6/chrome/overlayinfo/messenger
/usr/lib/mozilla-1.6/chrome/overlayinfo/messenger/content
/usr/lib/mozilla-1.6/chrome/overlayinfo/messenger/content/overlays.rdf
/usr/lib/mozilla-1.6/chrome/overlayinfo/navigator
/usr/lib/mozilla-1.6/chrome/overlayinfo/navigator/content
/usr/lib/mozilla-1.6/chrome/overlayinfo/navigator/content/overlays.rdf
/usr/lib/mozilla-1.6/components/myspell

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[mike@imp gnome-pim-20040124-vanilla]$ rpm -qf
/usr/lib/mozilla-1.6/chrome/overlayinfo/communicator
file /usr/lib/mozilla-1.6/chrome/overlayinfo/communicator is not owned
by any package
[mike@imp gnome-pim-20040124-vanilla]$ rpm -q mozilla
mozilla-1.6-0
    

Additional info:
Comment 1 W. Michael Petullo 2004-07-16 23:17:38 EDT
This is still a bug with mozilla-1.7-0.3.2.  In fact, upgrading from
mozilla 1.6 to mozilla 1.7 left behind a bunch of unowned cruft in
/usr/lib/mozilla-1.6.
Comment 2 W. Michael Petullo 2004-08-22 19:15:21 EDT
Still a bug in mozilla-1.7.2-0.3.0.  Again, cruft was left behind from
previous version.  If these file can't be included in the package,
could they at least be %ghost'ed?

Mozilla-1.7.2-0.3.0 creates these unowned files, in addition to the
ones listed above:

/usr/lib/mozilla-1.7.2/greprefs
/usr/lib/mozilla-1.7.2/init.d
/usr/lib/mozilla
/usr/lib/mozilla/plugins
Comment 3 Christopher Aillon 2005-03-31 05:45:06 EST

*** This bug has been marked as a duplicate of 74160 ***
Comment 4 W. Michael Petullo 2005-05-12 00:13:34 EDT
Looks almost right.  But what about these two:

[mike@imp ~]$ rpm -qf /usr/lib/mozilla*
file /usr/lib/mozilla is not owned by any package
file /usr/lib/mozilla-1.7.7 is not owned by any package

?
Comment 5 W. Michael Petullo 2005-05-22 23:27:55 EDT
I found another unowned directory and it looks like /usr/lib/mozilla-?.?.? is
properly owned.  This list is now:

/usr/lib/mozilla
/etc/gre.d
Comment 6 W. Michael Petullo 2005-12-26 20:44:54 EST
This list is now:

/usr/lib/mozilla
/etc/gre.d

Also, the following file is not owned, causing /usr/lib/mozilla-?.?.? to remain
for uninstalled versions of mozilla:

/usr/lib/mozilla-1.7.12/chrome/overlayinfo/messenger/content/overlays.rdf
Comment 7 W. Michael Petullo 2006-02-17 16:41:56 EST
As of mozilla-1.7.12-5, this list is now:

/usr/lib/mozilla
/etc/gre.d

Also, the following file is not owned, causing /usr/lib/mozilla-?.?.? to remain
for uninstalled versions of mozilla:

/usr/lib/mozilla-1.7.12/chrome/overlayinfo/messenger/content/overlays.rdf

Finally, /usr/include/mozilla-* and several sub-directories are not owned by the
mozilla-devel package.
Comment 8 Red Hat Bugzilla 2007-02-05 14:34:28 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 9 Matěj Cepl 2007-02-05 18:13:06 EST
Mozilla is not part of the Fedora/RHEL distributions anymore, and this seems to
be fixed in Firefox/Thunderbird packages anyway.

Note You need to log in before you can comment on or make changes to this bug.