Bug 74160 - files/directories not owned by mozilla rpm package
files/directories not owned by mozilla rpm package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
: 136197 143481 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2002-09-16 22:33 EDT by Chris Ricker
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.7.7-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 11:52:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-16 22:33:44 EDT
mozilla does not uninstall or upgrade cleanly.  I installed 8.0, which put:

mozilla-1.0.1-24
mozilla-chat-1.0.1-24
mozilla-mail-1.0.1-24
mozilla-nspr-1.0.1-24
mozilla-nss-1.0.1-24
mozilla-psm-1.0.1-24

on the system.  I then upgraded to mozilla-1.1 (rpm -Fvh on the corresponding
mozilla-1.1 rpms).  This left me with the following remnants of Mozilla 1.0.1,
now unowned by any RPM, that mozilla-1.0.1 put on the system but did not
uninstall as it should have when I upgraded:

[kaboom@skuld mozilla-1.0.1]$ ls -lR /usr/lib/mozilla-1.0.1/
/usr/lib/mozilla-1.0.1/:
total 20
drwxr-xr-x    3 root     root         4096 Sep 16 15:36 chrome
drwxr-xr-x    2 root     root         8192 Sep 16 15:36 components
drwxr-xr-x    3 root     root         4096 Sep 16 15:36 defaults
drwxr-xr-x    4 root     root         4096 Sep 16 15:36 res

/usr/lib/mozilla-1.0.1/chrome:
total 36
-rw-r--r--    1 root     root        29856 Sep 14 03:58 chrome.rdf
drwxr-xr-x    7 root     root         4096 Sep 14 03:58 overlayinfo

/usr/lib/mozilla-1.0.1/chrome/overlayinfo:
total 20
drwxr-xr-x    3 root     root         4096 Sep 14 03:58 communicator
drwxr-xr-x    3 root     root         4096 Sep 14 03:58 cookie
drwxr-xr-x    3 root     root         4096 Sep 14 03:58 editor
drwxr-xr-x    3 root     root         4096 Sep 14 03:58 messenger
drwxr-xr-x    3 root     root         4096 Sep 14 03:58 navigator

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/communicator:
total 4
drwxr-xr-x    2 root     root         4096 Sep 14 03:58 content

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/communicator/content:
total 4
-rw-r--r--    1 root     root         1592 Sep 14 03:58 overlays.rdf

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/cookie:
total 4
drwxr-xr-x    2 root     root         4096 Sep 14 03:58 content

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/cookie/content:
total 4
-rw-r--r--    1 root     root          491 Sep 14 03:58 overlays.rdf

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/editor:
total 4
drwxr-xr-x    2 root     root         4096 Sep 14 03:58 content

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/editor/content:
total 4
-rw-r--r--    1 root     root          562 Sep 14 03:58 overlays.rdf

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/messenger:
total 4
drwxr-xr-x    2 root     root         4096 Sep 14 03:58 content

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/messenger/content:
total 4
-rw-r--r--    1 root     root         1784 Sep 14 03:58 overlays.rdf

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/navigator:
total 4
drwxr-xr-x    2 root     root         4096 Sep 14 03:58 content

/usr/lib/mozilla-1.0.1/chrome/overlayinfo/navigator/content:
total 4
-rw-r--r--    1 root     root          856 Sep 14 03:58 overlays.rdf

/usr/lib/mozilla-1.0.1/components:
total 0

/usr/lib/mozilla-1.0.1/defaults:
total 4
drwxr-xr-x    2 root     root         4096 Sep 16 15:36 autoconfig

/usr/lib/mozilla-1.0.1/defaults/autoconfig:
total 0

/usr/lib/mozilla-1.0.1/res:
total 8
drwxr-xr-x    2 root     root         4096 Sep 16 15:36 dtd
drwxr-xr-x    2 root     root         4096 Sep 16 15:36 fonts

/usr/lib/mozilla-1.0.1/res/dtd:
total 0

/usr/lib/mozilla-1.0.1/res/fonts:
total 0
[kaboom@skuld mozilla-1.0.1]$
Comment 1 Chris Ricker 2003-04-04 10:47:07 EST
This is still broken with RHL 9 and mozilla-1.2.1. After I uninstalled
mozilla-1.2.1, I still had:

/usr/lib/mozilla-1.2.1/:
chrome
defaults
res
components

/usr/lib/mozilla-1.2.1/chrome:
icons
overlayinfo
chrome.rdf

/usr/lib/mozilla-1.2.1/chrome/icons:
default

/usr/lib/mozilla-1.2.1/chrome/icons/default:

/usr/lib/mozilla-1.2.1/chrome/overlayinfo:
communicator
navigator
messenger
inspector
editor
cookie

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/communicator:
content

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/communicator/content:
overlays.rdf

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/navigator:
content

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/navigator/content:
overlays.rdf

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/messenger:
content

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/messenger/content:
overlays.rdf

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/inspector:
content

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/inspector/content:
overlays.rdf

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/editor:
content

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/editor/content:
overlays.rdf

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/cookie:
content

/usr/lib/mozilla-1.2.1/chrome/overlayinfo/cookie/content:
overlays.rdf

/usr/lib/mozilla-1.2.1/defaults:
autoconfig
pref

/usr/lib/mozilla-1.2.1/defaults/autoconfig:

/usr/lib/mozilla-1.2.1/defaults/pref:

/usr/lib/mozilla-1.2.1/res:
dtd
fonts
inspector

/usr/lib/mozilla-1.2.1/res/dtd:

/usr/lib/mozilla-1.2.1/res/fonts:

/usr/lib/mozilla-1.2.1/res/inspector:

/usr/lib/mozilla-1.2.1/components:


left behind on the system....
Comment 2 Christopher Aillon 2005-03-31 05:45:12 EST
*** Bug 114475 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Aillon 2005-03-31 05:45:35 EST
*** Bug 136197 has been marked as a duplicate of this bug. ***
Comment 4 Christopher Aillon 2005-03-31 05:47:25 EST
*** Bug 143481 has been marked as a duplicate of this bug. ***
Comment 5 Christopher Aillon 2005-03-31 05:52:28 EST
*** Bug 81022 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Aillon 2005-03-31 05:54:44 EST
Gurgle.  Will get this fixed in devel soon.
Comment 7 Christopher Aillon 2005-05-06 11:52:14 EDT
Just checked in specfile changes to the package to own the files we have.  Will
be fixed in mozilla-1.7.7-4
Comment 8 Braden McDaniel 2006-07-10 17:49:55 EDT
This problem either persists or has recurred. Upgrading from mozilla 1.7.12 to
1.7.13 leaves a bunch of directories around.

Note You need to log in before you can comment on or make changes to this bug.