Bug 11448 - samba mount times out
Summary: samba mount times out
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
: 17820 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-16 16:09 UTC by Wagner T. Correa
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-26 03:43:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wagner T. Correa 2000-05-16 16:09:59 UTC
A few minutes after I use smbmount to mount on my Linux machine a SMB share
on a Windows NT server, it times out. Any subsequent attempts of accessing
it result in a "Input/output error" message. Also, smbumount doesn't work,
and I have to umount it as root.

Comment 1 Bill Nottingham 2000-05-16 16:58:59 UTC
The samba package in 6.2 should help solve the timeout
problem.

Comment 2 Wagner T. Correa 2000-05-16 17:15:59 UTC
I already have installed samba 2.0.6-9 and kernel 2.2.14-12, which are the ones
in RedHat 6.2, but the samba mount timeout problem persists.

Comment 3 Wagner T. Correa 2000-11-25 06:36:43 UTC
I added the following line to /etc/rc.d/rc.local, and the problem was solved:

while : ; do { df --sync --type=smbfs >/dev/null; sleep 123; }; done &


Comment 4 Bill Nottingham 2001-01-19 00:40:08 UTC
This *should* be fixed better in 2.0.7-24.

Comment 5 Urban Widmark 2001-01-28 22:34:57 UTC
The fix in 2.0.7-24 is not enough, it is not the only cause. There is a signal
related bug in smbfs in < 2.2.18 that commonly kill mounts with a
	"smb_retry: signal failed, error=-3"
message in the kernel log.

2.2.18 or 2.4.0 should improve on that, but there is still an issue with
SIGSTOP/SIGKILL. Running strace/gdb on multithreaded programs accessing smbfs
will not work well. The fix includes temporarily blocking those signals but also
make sure you don't sleep while blocking them.
(Hmm, maybe I should post it as a bug and let you keep track of my bugs for me
... :)

Keeping smbmount alive have been the #1 problem in smbfs, judging from the samba
mailinglist. I would not be surprised to see it come back.

Bugs# 17820, 19623 appear to be duplicates of this.

/Urban


Comment 6 Bill Nottingham 2001-01-29 03:17:16 UTC
*** Bug 17820 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.