Bug 19623 - smbmount does not restore the connection after connection failure
Summary: smbmount does not restore the connection after connection failure
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
: 21385 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-23 17:09 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 21:04:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-23 17:09:48 UTC
Seems that smbmount does not restore the connection after a failure.
To reproduce do the following (the ssh is used only to demonstrate the 
problem, it is irrevant for the problem).

1. Open a local tunnel to server host
ssh -L 8001:localhost:139 user@server.address.com
a tunnell local port (8001)  will be open.

2. mount a disk using smbmount via this tunnel.
smbmount //127.0.0.1/share_name /mnt -o username=samba_user_name,port=8001
Now you can browse the mounted filesystem
ls -l /mnt

3. Close ssh session (do not forget to close the terminal, because
otherwise
the ssh will continue to provide tunnell)
so the tunnell will not be available.
Do ls -l /mnt
you will get "IO error" message as it should be.

4. Re-establish ssh session (repeat item 1)
doing ls -l /mnt you receive "IO error"
despite the connection was re-established. 
Buy the way Windows NT reestablishes the connection automatically in such
cases.

The only way to fix "IO error" this is to
umount /mnt and then mount it again (item #2)

Comment 1 giulioo 2000-10-24 12:10:29 UTC
This seems to be the same problem of smbmount not restoring the connection 
after win9x/nt servers reboots.
This is a known smbfs/samba issue.

See
http://www.hojdpunkten.ac.se/054/samba/
for patches about this.


Comment 2 Bill Nottingham 2000-11-27 19:30:32 UTC
*** Bug 21385 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2001-01-19 00:26:31 UTC
Urban's latest bugfix patch will be in 2.0.7-24.

Comment 4 Need Real Name 2001-05-09 18:48:51 UTC
This bug was fixed in Rawhide, but recent samba upgrade

rpm -q samba
samba-2.0.8-0.7

seems have this bug again.

Comment 5 Need Real Name 2001-07-03 21:04:25 UTC
The problem still exists in samba-2.0.10-0.7

Comment 6 Trond Eivind Glomsrxd 2001-08-09 03:47:04 UTC
This seems fixed in samba 2.2, and verified to work in 2.2.1a-3


Note You need to log in before you can comment on or make changes to this bug.