Bug 114480 - default 'Computer' entry has broken link
default 'Computer' entry has broken link
Status: CLOSED DUPLICATE of bug 119446
Product: Red Hat Raw Hide
Classification: Retired
Component: nautilus (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-01-28 11:25 EST by Bill Nottingham
Modified: 2014-03-16 22:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-01-28 11:25:36 EST
[notting@nostromo: ~]$ rpm -q nautilus gnome-vfs2

Double click on 'Computer'.

Double click on 'Network'

Error dialog:

The action associated with network:/// is invalid

You can configure GNOME to associate a different application or viewer
with this file type. Do you want to associate an application or viewer
with this file type now?

<cancel> <associate action>

Is 'associate action' really HIGgy?
Comment 1 Bill Nottingham 2004-01-28 11:26:38 EST
Click on 'Associate action':

Application "nautilus" (process 2150) has crashed
due to a fatal error.
(Segmentation fault)

Comment 2 Gary Peck 2004-01-29 02:40:52 EST
I have the same problem. This is using nautilus-2.5.5-1. Furthermore,
if I select File/Open Location... and type in smb://computername, it
shows the shared folders on that server with no problem.
Double-clicking on one of the folders to open it produces the same
dialog box as Bill explains above. If I then again select File/Open
Location... and type in smb://computername/sharename (using the shared
folder I just tried to double-click), it opens the folder with no
problem. From there I can browse deeper into the shared folder's
directory structure with no more problems.
Comment 3 Alexander Larsson 2004-02-09 06:22:46 EST
Fixed in gnome-vfs2 2.5.6-3
Comment 4 Gary Peck 2004-02-15 19:46:10 EST
Just upgraded to gnome-vfs2-2.5.7-1 and this problem is only partially
fixed. Opening Network now works, and opening a computer inside
Network also works. But when I try to open a shared folder inside a
computer, I still get the "Associate Action" dialog box and the folder
doesn't open.

The way I found to fix this was to go to Main Menu -> Preferences ->
File Types and Programs. Click "Add Service". Type in a description,
"smb" for the Protocol, and "nautilus %s" for the Program. After that,
opening shared folders worked fine. Shouldn't this entry be part of
the defaults?

(doesn't look like I'm allowed to reopen this bug. should i refile
under a new bug?)
Comment 5 Bill Nottingham 2004-02-15 22:21:25 EST
Comment 6 Alexander Larsson 2004-02-16 03:32:43 EST
smb: certainly should not be in the mime info. You don't want to
launch a new nautilus every time you open a directory on smb. I don't
understand why it doesn't work though. It works well for me...
Comment 7 Gary Peck 2004-02-16 05:31:20 EST
Anything I can do to help narrow down the problem? I'm running the
latest packages from Fedora devel. The computers are on a local LAN
and  part of the same workgroup. I'm connecting to Samba (the version
from RedHat 7.2), Windows 2000, and Windows XP servers.

I can try removing and reinstalling all the packages involved. Would
that just be gnome-vfs2, gnome-vfs2-smb, and nautilus?
Comment 8 Alexander Larsson 2004-02-17 03:59:41 EST
Comment 9 Gary Peck 2004-02-23 19:44:21 EST
I removed the above packages (along with gnome-vfs2-devel), made sure
there were no left over files, and then reinstalled the packages. I'm
still seeing the same problem.
Comment 10 Tim Hawkins 2004-02-25 04:30:20 EST
I see the same problem too, unassociated action when double clicking
on smb:// share lists
Comment 11 Alexander Larsson 2004-04-06 12:29:55 EDT

*** This bug has been marked as a duplicate of 119446 ***
Comment 12 Red Hat Bugzilla 2006-02-21 14:00:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.