Bug 119446 - Links sometimes give 'The action associated with <uri> is invalid'
Links sometimes give 'The action associated with <uri> is invalid'
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: 114480 116574 119536 119912 119974 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
Reported: 2004-03-30 11:40 EST by Michael Opdenacker
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-07 13:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Opdenacker 2004-03-30 11:40:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:

I'm using Fedora Core 2 test 2 with the Gnome desktop
(all packages installed).

When I create a new user, log as this user and clicked
on "System Settings" from "Start Here", I got the below
error dialog:

The action associated with "system-settings" is invalid.

See http://michaelo.free.fr/issues/mar30_2004/system_settings.png
for a screen capture containing the full error message.

This can be fixed by copying the 
~/.nautilus/metafiles/system-settings\:%2F%2F%2F.xml file
from another user account where this file exists.

Here are its contents:
<?xml version="1.0"?>
<directory><file name="." window_geometry="700x555+821+527"
name="Server" window_geometry="500x300+925+37"

It seems that this file should automatically be created when the
Gnome desktop is run for the first time.

I also faced the same error with another user, but this time
with the "Preferences" shortcut. "System Settings" was fine
if I remember well.

I had this issue too with my main user account, but it disappeared
after some time (can't list the many things I did in between).

So, I can't tell exactly under which circumstances this bug
happens. I hope other testers can help to locate the cause
of this bug.



Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create a new user account
2. Open a Gnome session with this new account
3. Go to "System Settings" in "Start Here"

Additional info:
Comment 1 Need Real Name 2004-04-01 17:41:59 EST
I get this problem with just the Preferences item in start-here.
Comment 2 Alexander Larsson 2004-04-06 10:27:07 EDT
Its very strange that adding the metadata file fixed this. That file
only stores data about the position of icons, window size and other
pretty unimportant things. It should not even be used to figure out
the associated action with something.

How did the system-settings\:%2F%2F%2F.xml look that it didn't work
with? Or was there none?
Comment 3 Alexander Larsson 2004-04-06 10:28:17 EDT
bug 119536 looks related.
Comment 4 Michael Opdenacker 2004-04-06 10:31:54 EDT
Hi Alexander,

Thank you for investigating this!
There was none (no system-settings\:%2F%2F%2F.xml file).


Comment 5 Alexander Larsson 2004-04-06 12:04:12 EDT
*** Bug 119974 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Larsson 2004-04-06 12:05:55 EDT
*** Bug 119536 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Larsson 2004-04-06 12:17:02 EDT
*** Bug 119912 has been marked as a duplicate of this bug. ***
Comment 8 Alexander Larsson 2004-04-06 12:29:12 EDT
*** Bug 116574 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Larsson 2004-04-06 12:29:58 EDT
*** Bug 114480 has been marked as a duplicate of this bug. ***
Comment 10 Mark Nelson 2004-04-06 12:38:37 EDT
I can confirm the same problem happening for sftp:// and ssh:// server
mounts using the file->connect to server drop down.  Nautilus does
attempt to connect to the server (can be seen from the other machines
syslog).  I also have been able to reproduce this bug trying to access
http:// links on the desktop created by dragging from galeon.

I've created a gnome bugzilla entry for this bug as well:

Comment 11 Malcolm Cropp 2004-04-15 04:20:22 EDT
This is very similar to a problem I have on my Test 2 install. I get
that message when trying to browse windows shares from my testbox. I
can access the computers fine but when trying to descend into a shared
folder I get the "no action associated" message.
There is a shot of it.
Comment 12 Alexander Larsson 2004-04-16 11:21:22 EDT
Everyone who has this problem, please upgrade to gnome-vfs2-2.6.0-5
and nautilus-2.6.0-4 and tell me what happens with that.
Comment 13 Jeffrey C. Ollie 2004-04-16 23:09:33 EDT
I have gnome-vfs2-2.6.0-5 and nautilus-2.6.0-4 installed and still
have the problem.
Comment 14 Sean Earp 2004-04-17 11:45:53 EDT
I updated to the mentioned versions of gnome-vfs2 and nautilus, and still get the "action 
associated with <whatever> is invalid"  The easiest way for me to reproduce the problem 
is to double click on the Floppy or CD-ROM icons on my desktop.  It fails 100 percent of 
the time.
Comment 15 Michael Opdenacker 2004-04-28 11:08:04 EDT
Checked that this still happens with FC2 T3
Comment 16 Michael Opdenacker 2004-04-28 11:12:25 EDT
Changing version to test3
Comment 17 Alexander Larsson 2004-05-13 06:12:13 EDT
This should be fixed for system-settings:// and the other vfolders in
Comment 18 Gary Peck 2004-05-17 05:14:57 EDT
I'm running gnome-vfs2-2.6.0-8 and nautilus-2.6.0-4 and am still
seeing this problem when double-clicking on SMB shares. Typing in the
full address (smb://computername/sharename) manually works fine though.

Also, as of recently, "Windows Network" no longer displays any
available LAN computers. Though that's probably not related.
Comment 19 Warren Togami 2004-05-17 13:22:43 EDT
Please ask the mailing list to see if anybody else can reproduce the
Windows Network problem.
Comment 20 Michael Opdenacker 2004-05-25 04:29:12 EDT
I'm not longer facing the original issue I reported with FC2 final...
You may close this bug if everyone agrees.


Comment 21 Gary Peck 2004-07-29 22:49:50 EDT
Just wanted to mention that I still am seeing this issue with the
current FC rawhide. gnome-vfs2-2.6.0-9 and nautilus-2.6.0-6.

However, the Windows Network problem (below) seems to have been fixed.

> Also, as of recently, "Windows Network" no longer displays any
> available LAN computers. Though that's probably not related.
Comment 22 Alexander Larsson 2004-09-06 09:07:18 EDT
I think i finally fixed this in gnome-vfs cvs.
The fix will be in rawhide when next i update the package.
Comment 23 Matthew Miller 2006-07-07 13:47:05 EDT
Marking fixed in rawhide as per comment #22.

Note You need to log in before you can comment on or make changes to this bug.