Bug 11450 - Installer crashes during install (all modes)
Installer crashes during install (all modes)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
:
: 11449 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-16 12:19 EDT by Michael Morris
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 14:15:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Morris 2000-05-16 12:19:29 EDT
Redhat 6.2 Installer crashes consistantly using a Pentium-90 Trident Video
Card, 40 Megs RAM, installed from CDROM (24x). Crashes during install in
Graphic, Text, and Expert modes as well.

Following Text:

Traceback (innermost, last)
 File "usr/bin/anaconda", line 342 in inf.run (todo, test=test)
 File "usr/lib/anaconda/text.py", line 1165 in run rc=apply (step[i](),
step[2])
 File "usr/lib/anconda/text.py", line 702, in __call__ if todo.doInstall()
 File "usr/lib/anaconda/todo.py", line 1280, in doInstall self.set
DefaultRunlevel()
 File "/usr/lib/anaconda/todo.py", line 960, in set DefaultRunlevel
inittab.open(self.instPath + '/etc/inittab','r')

 IOError [errno2] No such file or directory: 'mnt/sysimage/etc/inittab'

I have had Zero luck getting this installed, and Always with the same
error on different disks as well.

Thanks,
Michael
Comment 1 Michael Morris 2000-05-16 12:25:59 EDT
Addendum:

This is right at the "Post Install" screen.
IDE, not SCSI.

Michael
Comment 2 Michael Morris 2000-05-16 14:38:59 EDT
*** Bug 11449 has been marked as a duplicate of this bug. ***
Comment 3 Michael Morris 2000-05-16 14:46:59 EDT
Tried this on a separate drive as well, a 540MB instead of the 1.4GB I was
originally trying.  No go either.  There is a NIC in the machine, but this has
been attempted both with it in and out.

Doesn't work for any type of install either Custom/Gnome/KDE/Server etc.  All
produce the same message after copying packages under different graphic modes.

When rebooted, gives the "Missing operating System" error.  Boot from floopy
works fine, can mount the partition, but when trying to install LILO no
lilo.conf file exists.  Attempted to create one, but Lilo then will still not
install, can't remember that error though.
Comment 4 Jan Welti 2000-05-17 10:36:59 EDT
I believe this is a duplicate of bug# 10967
Comment 5 Michael Fulbright 2000-06-09 18:18:58 EDT
If you switch to the second VC using the key sequence ALT-CNTL-F2, and then
do the command

ls /mnt/sysimage/etc

do you see the inittab file?

Also, it would be good to know if the 'setup' package is installed.
Comment 6 m_j_conroy 2000-06-12 13:37:06 EDT
I have experienced a similar failure.  I need to have a boot setup that allows 
me to load RH6.2 from a server computer (using DHCP for dynamic assignment 
initially) exposing /mnt/cdrom as an NFS directory using kickstart.  I get as 
far as getting a temp IP address, mounting the CD, and then anaconda barfs with:

File "/usr/bin/anaconda", line 342, in ?
   intf.run(todo, test = test)
File "/usr/lib/anaconda/text.py", line 1165, in run
   rc = apply(step[1](), step[2])
File "/usr/lib/anaconda/text.py", line 584, in __call__
   todo.getCompsList ()
File "/tmp/updates/todo.py", line 475, in getCompsList
   self.updateInstClassComps()
File "/tmp/updates/todo.py", line 491, in updateInstClassComps
   self.comps[n].select(1)
File "/usr/lib/anaconda/comps.py", line 172, in __getitem__
   return self.compsDict[key]
KeyError: Workstation

My packages section of my .ks file is
%packages
@ Workstation

This happens on a:

MB = DFI K6BV3+
CPU = AMD K6 450
ETH0,1 = DLINK PCI
MEM = 32MB DIMM
HD = WD 4 GB
BIO = AWARD 4.51PG
MDM = USR COURIER VEVERYTHING

Please help!
Comment 7 Brock Organ 2000-11-02 14:15:17 EST
m_j_conroy,

does a package group list of:

%packages
@ Base
@ X Window System
@ GNOME Workstation

work any better for you ...?

----------------
michael,

unfortunately, I am unable to reproduce this behavior on any of our closest test
lab hardware (ie pentium 200 Mhz systems w/similar but not exact disks) ... :(

do you have the same problem when using any other video card w/that same machine
...?

Note You need to log in before you can comment on or make changes to this bug.