Bug 1145694 - Live Storage Migration fails when trying to return disk to its original Storage domain and Disk profile noting "Cannot move Virtual Machine Disk. Disk Profile doesn't match provided Storage Domain"
Summary: Live Storage Migration fails when trying to return disk to its original Stora...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Gilad Chaplik
QA Contact: Lukas Svaty
URL:
Whiteboard: sla
: 1147274 (view as bug list)
Depends On: 1105846 1149460
Blocks: rhev35betablocker rhev3.5beta3 rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-09-23 14:11 UTC by Gilad Lazarovich
Modified: 2016-06-23 04:52 UTC (History)
18 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:15:30 UTC
oVirt Team: SLA


Attachments (Terms of Use)
Engine and VDSM logs showing the LSM failure due to Disk Profile not getting updated (1015.98 KB, application/x-gzip)
2014-09-23 14:11 UTC, Gilad Lazarovich
no flags Details
all logs from engine and hosts (3.14 MB, application/x-gzip)
2014-11-03 15:25 UTC, Nikolai Sednev
no flags Details
screenshot (198.24 KB, image/png)
2014-11-03 15:25 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 33483 master MERGED core: persist disk image parameters for live migration Never
oVirt gerrit 33530 ovirt-engine-3.5 MERGED core: persist disk image parameters for live migration Never

Description Gilad Lazarovich 2014-09-23 14:11:37 UTC
Created attachment 940459 [details]
Engine and VDSM logs showing the LSM failure due to Disk Profile not getting updated

Description of problem:
Live Storage Migration fails when trying to return disk to its original Storage domain and Disk profile noting "Error while executing action: Cannot move Virtual Machine Disk. Disk Profile doesn't match provided Storage Domain"

Version-Release number of selected component (if applicable):
3.5 vt3.1

How reproducible:
100%

Steps to Reproduce:
1. Live migrate a disk from a running VM from Storage Domain 1 to Storage Domain 2 (using the new Domain's Disk profile)
2. Once the migration has completed, try and migrate the disk back to Storage Domain 1

Actual results:
An error is thrown immediately noting: "Error while executing action: Cannot move Virtual Machine Disk. Disk Profile doesn't match provided Storage Domain"

Expected results:
The migration should be successful

Additional info:
I've noticed that the Disk Profile isn't correctly switched as part of the Live Storage migration (or Move), if you manually change the Disk Profile under the Edit Disk screen, the migration will go through successfully.  See attached logs

Comment 1 Tal Nisan 2014-09-24 10:29:57 UTC
Gilad, can you please have a look? Seems like the disk profiles feature introduced a regression here in the flow

Comment 2 Gilad Chaplik 2014-09-28 07:40:45 UTC
Thanks guys.

Not sure it's a blocker though, since in order to get the bug, you ought to create new disk profile.

Comment 3 Allon Mureinik 2014-09-28 08:15:06 UTC
(In reply to Gilad Chaplik from comment #2)
> Thanks guys.
> 
> Not sure it's a blocker though, since in order to get the bug, you ought to
> create new disk profile.
This means that if you use one of 3.5's top new features (= disk profiles) you lose the ability to use one of pre-existing top features (=LSM).
Sounds like a blocker to me, but ultimately, it's a PM decision.

Comment 4 Gilad Chaplik 2014-09-29 13:28:01 UTC
*** Bug 1147274 has been marked as a duplicate of this bug. ***

Comment 5 Allon Mureinik 2014-09-30 13:11:18 UTC
Gilad, I see the patch was merged to 3.5.
Can this BZ be moved to MODIFIED, or are we pending an additional patch?

Comment 6 Gilad Chaplik 2014-09-30 14:38:24 UTC
thanks Allon, was afk, moving to MODIFIED

Comment 7 Eyal Edri 2014-10-07 07:12:50 UTC
this bug status was moved to MODIFIED before engine vt5 was built,
hence moving to on_qa, if this was mistake and the fix isn't in,
please contact rhev-integ@redhat.com

Comment 8 Nikolai Sednev 2014-11-03 15:23:12 UTC
I saw that after sending "move" via WEBUI to get live storage migration started, disk enters in to the locked state and nothing happens anymore with it over 2 days long.
Logs and print-screen attached.

Components on which I've tested are as follows:
rhevm-3.5.0-0.18.beta.el6ev.noarch
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64
libvirt-0.10.2-46.el6_6.1.x86_64
vdsm-4.16.7.2-1.el6ev.x86_64
ovirt-hosted-engine-ha-1.2.4-1.el6ev.noarch
ovirt-hosted-engine-setup-1.2.1-2.el6ev.noarch
sanlock-2.8-1.el6.x86_64
ovirt-host-deploy-1.3.0-1.el6ev.noarch

Comment 9 Nikolai Sednev 2014-11-03 15:25:18 UTC
Created attachment 953152 [details]
all logs from engine and hosts

Comment 10 Nikolai Sednev 2014-11-03 15:25:48 UTC
Created attachment 953153 [details]
screenshot

Comment 11 Gilad Chaplik 2014-11-04 16:04:37 UTC
Nikolai, 

Your host doesn't support live snapshot-ing, there's a bug to block the live move in this case (bug 1105846). moving back to ON_QA - should be checked on hosts that support it.

Comment 12 Lukas Svaty 2014-11-27 12:42:28 UTC
verified in ovirt-engine-3.5.0-0.22

Comment 14 Lukas Svaty 2014-11-27 12:59:27 UTC
This bug should not be dependant on BZ#1105846. As in Description it is stated that live migration of disk succeeded the first time -> It is supported. Thus this should be verified on hosts that support live migration (as was done in verification process). 

Blocking live migration when it is not supported by host is not relevant to this one.

Comment 15 Eyal Edri 2015-02-17 17:15:30 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.