Bug 114733 - Two shutdown messages for interface, second one fails
Two shutdown messages for interface, second one fails
Status: CLOSED DUPLICATE of bug 127487
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2004-02-01 19:38 EST by Andre Robatino
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2004-02-01 19:38:19 EST
Description of problem:
  At shutdown, there are two successive attempts to shutdown the xDSL
interface.  The first succeeds and the second fails (since the
interface is already down).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Make sure xDSL interface is up.
2.  Logout, and then from the login screen, do a shutdown.  It's
necessary to shut down this way since a direct shutdown usually
doesn't let one see the shutdown messages.
Actual results:
  About half the time, there will be two successive shutdown attempts
for the xDSL interface.  The first succeeds and the second fails,
since the interface is already down.

Expected results:
  There should be exactly one successful shutdown attempt for the xDSL

Additional info:
  It appears that the fix for bug #109601 does more than one shutdown
attempt for the xDSL interface, and relies on an error code on the
second attempt to determine whether the interface is already down. 
Obviously this error code is not reliable.  A more elegant approach is
to make a list of interfaces to be brought down, in the correct order,
and attempt to shut each one down just once.  The bug is not a big
deal, except that any spurious error message may send people on a wild
goose chase when trying to track down other problems.  I noted this
problem in bug #109601, but it was not acted on, so I've filed a
separate bug report.
Comment 1 Bill Nottingham 2004-07-27 12:02:18 EDT

*** This bug has been marked as a duplicate of 127487 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.