Bug 114734 - undefined symbol in mod_dav_svn.so
undefined symbol in mod_dav_svn.so
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
: 126191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-01 20:03 EST by Todd A. Jacobs
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 05:23:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Todd A. Jacobs 2004-02-01 20:03:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
Cannot integrate subversion into Apache because of an apparent error
in the mod_dav_svn-0.32.1-1 package. Starting Apache with mod_dav_svn
installed leads to the following errors:

Feb  1 16:27:44 gateway httpd: Cannot load
/etc/httpd/modules/mod_dav_svn.so into server:
/etc/httpd/modules/mod_dav_svn.so: undefined symbol: dav_xml_get_cdata
                                                                     
          
Feb  1 16:27:44 gateway httpd: httpd startup failed

Version-Release number of selected component (if applicable):
mod_dav_svn-0.32.1-1

How reproducible:
Always

Steps to Reproduce:
1. yum install mod_dav_svn
2. service httpd start
3. tail /var/log/messages to view errors
    

Actual Results:  Apache fails to start because of errors.

Expected Results:  Apache should run, and include support for subversion.

Additional info:

httpd-2.0.48-1.2
subversion-0.32.1-1

/etc/httpd/conf/httpd.conf includes:
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so

/etc/httpd/conf.d/subversion.conf includes:
LoadModule dav_svn_module     modules/mod_dav_svn.so
LoadModule authz_svn_module   modules/mod_authz_svn.so
Comment 1 Joe Orton 2004-02-02 04:09:15 EST
This error should only occur when mod_dav_svn is loaded before
mod_dav.so.  Can you attach your complete httpd.conf, and check that the

Include conf.d/*.conf

appears *after* the LoadModule lines?
Comment 2 Todd A. Jacobs 2004-02-03 13:33:42 EST
That fixed the problem. It appears the problem is caused when you
upgrade from Red Hat 8.0 to Fedora Core 1, because the Red Hat 8.0
httpd.conf file has the Include directives BEFORE the Loadodule lines.
Comment 3 Frank Büttner 2004-06-17 06:25:18 EDT
*** Bug 126191 has been marked as a duplicate of this bug. ***
Comment 4 Frank Büttner 2004-06-17 06:28:56 EDT
The same problem when upgrade from RH 9 to FC1.
Comment 5 Matthias Saou 2004-07-22 14:52:22 EDT
I got bitten by this one too at some point, but really can't think of
an easy way of fixing it without going messing with the existing flat
file httpd.conf... which doesn't sound like a bright idea.

Or would it be possible to add a few lines to the subversion
httpd/conf.d/ file in order to do something like "if the dav module
isn't loaded, load it now"? That is, of course, if trying to load it
again later doesn't produce an error.
Comment 6 Joe Orton 2005-01-13 05:23:05 EST
Per Matthias' comment it's really not easy to fix this without
automatic munging of httpd.conf, which is not really desirable.  It's
simply the case that after an upgrade sometimes the config files will
need some manual tweaking, unfortunately.

Note You need to log in before you can comment on or make changes to this bug.