Bug 1147860 - [Tracker] Exporting, moving and copying LUN disks and VM's LUN disks fail in the REST API
Summary: [Tracker] Exporting, moving and copying LUN disks and VM's LUN disks fail in ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Vered Volansky
QA Contact: Carlos Mestre González
URL:
Whiteboard: storage
Depends On: 1126425 1147861 1147863 1147870 1147873 1147874 1288366
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-30 08:36 UTC by Idan Shaby
Modified: 2016-02-10 19:20 UTC (History)
9 users (show)

Fixed In Version: 3.6.0-12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 11:26:02 UTC
oVirt Team: Storage
rule-engine: ovirt-3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1215623 0 urgent CLOSED [BLOCKED] Deploying on a shared block device, hosted-engine is unable to add the VM Disk as a direct LUN 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1223482 0 urgent CLOSED ovirtsdk.api.API.disks.add fails due to a server side java.lang.NullPointerException 2021-02-22 00:41:40 UTC
oVirt gerrit 45361 0 master MERGED core: Avoid NPEs on illegal LUN disk operations Never
oVirt gerrit 45405 0 master MERGED core: Moved getDiskDao to AuditLogBase Never
oVirt gerrit 45775 0 ovirt-engine-3.6 MERGED core: Moved getDiskDao to AuditLogBase Never
oVirt gerrit 45776 0 ovirt-engine-3.6 MERGED core: Avoid NPEs on illegal LUN disk operations Never
oVirt gerrit 45805 0 master MERGED webadmin: imageGroupId passed to parameters Never
oVirt gerrit 45854 0 master MERGED core: Avoid NPE when validating non-LUN disks Never
oVirt gerrit 45855 0 ovirt-engine-3.6 MERGED core: Avoid NPE when validating non-LUN disks Never

Internal Links: 1215623 1223482

Description Idan Shaby 2014-09-30 08:36:05 UTC
Description of problem:
When trying to export/move a VM LUN disk, and when trying to export/move/copy a LUN disk in the REST API, a "500 Internal Server Error" is returned.

Version-Release number of selected component (if applicable):
4792bd921cd73b01a990065607561c4ad2b2c486

How reproducible:
100%

Steps to Reproduce:
1. Create a VM.
2. Add an external disk to the VM.
3. From the REST API, run a POST request with one of the operations - export/move/copy.

Actual results:
A "500 Internal Server Error" is returned.

Expected results:
An informative error message should be returned, or maybe we should even remove these options for LUN disks in the REST API.


Additional info:

Comment 1 Juan Hernández 2015-07-07 08:39:34 UTC
Do we still plan to fix this for 3.6.0? As it isn't really of high severity I'd suggest to move it to 4.0.

Comment 2 Allon Mureinik 2015-07-07 09:16:34 UTC
(In reply to Juan Hernández from comment #1)
> Do we still plan to fix this for 3.6.0? As it isn't really of high severity
> I'd suggest to move it to 4.0.
I guess this is basically a capacity issue.
I'd prefer leaving this in 3.6.0 and pushing them out only when we we're nearing the finish line.

Comment 3 Carlos Mestre González 2015-09-22 11:27:36 UTC
Marking this as tested, verified on move/export/copy for lun disks and move/export for vm disk, message is the same except for the specific $action (move, copy, export):

<fault>
<reason>Operation Failed</reason>
<detail>
[Cannot $action Virtual Machine Disk. Action is unsupported for the specified disk type (LUN).]
</detail>

3.6.0-13

One minor issue is when calling the api for the disk (not vm disk) the message is the same, "Virtual Machine Disk", when that's not the case. I think the message should be fixed accordingly if it's a VM disk or just a 'regular disk'.

Allon/Yaniv what do you think?

Comment 4 Allon Mureinik 2015-09-24 07:48:07 UTC
The term Virtual Machine Disk is used throughout the engine CDA messages, not only for these newly added messages.

It's a trivial patch to change it, but I'm not sure that would be the right thing to do.
Leaving to Yaniv to decide.

Comment 5 Yaniv Lavi 2015-10-14 12:38:58 UTC
(In reply to Allon Mureinik from comment #4)
> The term Virtual Machine Disk is used throughout the engine CDA messages,
> not only for these newly added messages.
> 
> It's a trivial patch to change it, but I'm not sure that would be the right
> thing to do.
> Leaving to Yaniv to decide.

I think 'Virtual Disk' or 'vDisk' should be used to describe the VM's disks.
But we should open a new request for this since this is not a critical to fix in 3.6.

Comment 6 Allon Mureinik 2015-10-14 13:58:16 UTC
(In reply to Yaniv Dary from comment #5)
> (In reply to Allon Mureinik from comment #4)
> > The term Virtual Machine Disk is used throughout the engine CDA messages,
> > not only for these newly added messages.
> > 
> > It's a trivial patch to change it, but I'm not sure that would be the right
> > thing to do.
> > Leaving to Yaniv to decide.
> 
> I think 'Virtual Disk' or 'vDisk' should be used to describe the VM's disks.
> But we should open a new request for this since this is not a critical to
> fix in 3.6.

Agreed. I opened bug 1271698 to track this for the next release, and am marking this one as VERIFIED based on comment 3.

Comment 7 Sandro Bonazzola 2015-11-04 11:26:02 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.