Bug 1271698 - Change terminology from "virtual machine disk" to "virtual disk"
Change terminology from "virtual machine disk" to "virtual disk"
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
4.0.0
Unspecified Unspecified
low Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Idan Shaby
Elad
: FutureFeature, StudentProject
Depends On:
Blocks: 1429251
  Show dependency treegraph
 
Reported: 2015-10-14 09:55 EDT by Allon Mureinik
Modified: 2017-03-05 17:31 EST (History)
8 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:51:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
gklein: testing_plan_complete-
ylavi: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54713 master MERGED core: Rename "Virtual Disk" to "Disk" 2016-03-17 12:44 EDT

  None (edit)
Description Allon Mureinik 2015-10-14 09:55:44 EDT
oVirt refers to "virtual machine disks". This terminology, however, is inaccurate - a disk can belong to a template, or be completely detached (floating).
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:58:34 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Kaul 2015-11-26 10:49:41 EST
Setting as 'StudentProject', in the hope that all changes are indeed UI only.
Comment 3 Elad 2016-04-14 06:55:30 EDT
I'm not sure how to verify since we have many places where the "virtual (machine) disk" terminology is used.

Idan, what do you suggest?
Comment 4 Idan Shaby 2016-04-18 01:35:22 EDT
The idea is to distinguish between a general virtual disk (that can be a vm disk or even a template or floating disk) and a vm disk.
In case that the disk must belong to a vm, it's ok to call it a vm disk.
In case that it doesn't necessarily belong to a vm, it should be called virtual disk.
Comment 5 Elad 2016-04-18 08:14:21 EDT
Following a f2f conversation with Idan and Tal Nisan, they suggested to test that the terminology is changed in UI for the basic flows (disk creation, deletion, move etc.)
Comment 6 Elad 2016-04-18 08:58:52 EDT
Tested basic disk operations with floating disks, attached to VM disks and attached to template disk.
The terminology used in each is correct, for example, for a disk attached to VM, the following event log is shown when extending it:

"  Size of the disk 'test1_Disk1' was successfully updated to 2 GB by admin@internal.  "

Another example, of removal of a disk attached to template:

" VM test1 powered off by admin@internal (Host: blond-vdsh) (Reason: No reason was returned for this operation failure. See logs for further details.).  "

Verified using:
ovirt-engine-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch
Comment 7 Sandro Bonazzola 2016-07-05 03:51:38 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.