Bug 1147966 - Unregister Content Hosts as Bulk Actions fails with "Resource Not Found" Error
Summary: Unregister Content Hosts as Bulk Actions fails with "Resource Not Found" Error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1132363
TreeView+ depends on / blocked
 
Reported: 2014-09-30 12:25 UTC by David Gurtner
Modified: 2017-02-23 20:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:05:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (77.97 KB, image/png)
2015-07-10 20:59 UTC, sthirugn@redhat.com
no flags Details
another screenshot (77.75 KB, image/png)
2015-07-10 21:00 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1223568 None None None Never
Red Hat Bugzilla 1244309 None None None Never

Internal Links: 1223568 1244309

Description David Gurtner 2014-09-30 12:25:39 UTC
Description of problem:

In the WebUI when using the "Unregister Content Hosts" command as a Bulk Action the following error is displayed:

Task <uuid>: RestClient::ResourceNotFound: 404 Resource Not Found


How reproducible:
always

Steps to Reproduce:
1. Navigate to Hosts -> Content Hosts
2. Select at least 2 hosts
3. Click "Bulk Actions"
4. Click "Unregister Content Hosts"

Actual results:

The following error message is displayed:
Task <uuid>: RestClient::ResourceNotFound: 404 Resource Not Found

Expected results:

All selected Content Hosts get successfully unregistered

Comment 1 RHEL Program Management 2014-09-30 12:34:08 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2015-07-10 16:45:19 UTC
unable to reproduce this in 6.1.0. Moving ON_QA for an official re-test

Comment 4 sthirugn@redhat.com 2015-07-10 20:58:49 UTC
Failed.  An UI error is thrown when trying to do a bulk unregister (screenshot attached)

Version: Sat 6.1 GA Snap 11

Comment 5 sthirugn@redhat.com 2015-07-10 20:59:15 UTC
Created attachment 1050797 [details]
screenshot

Comment 6 sthirugn@redhat.com 2015-07-10 21:00:22 UTC
Created attachment 1050798 [details]
another screenshot

Comment 7 sthirugn@redhat.com 2015-07-17 18:32:31 UTC
The original issue mentioned in this bug is fixed now in Sat 6.1 GA Snap 13.  But there are two outstanding related bugs.  See:
https://bugzilla.redhat.com/show_bug.cgi?id=1244309
https://bugzilla.redhat.com/show_bug.cgi?id=1223568

Comment 9 Bryan Kearney 2015-08-12 16:05:26 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.