Bug 1223568 - content-host unregister shows error in content-host's /var/log/messages
Summary: content-host unregister shows error in content-host's /var/log/messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-05-20 21:59 UTC by sthirugn@redhat.com
Modified: 2019-09-26 16:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:51:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug (760.36 KB, application/x-xz)
2015-05-20 21:59 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 13957 None None None 2016-04-22 16:40:35 UTC
Red Hat Bugzilla 1147966 None CLOSED Unregister Content Hosts as Bulk Actions fails with "Resource Not Found" Error 2019-06-06 14:34:11 UTC

Internal Links: 1147966

Description sthirugn@redhat.com 2015-05-20 21:59:03 UTC
Created attachment 1027884 [details]
foreman-debug

Description of problem:
[Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 5

How reproducible:
Always

Steps to Reproduce:
1. Register a content host to Satellite 6 and watch /var/log/messages in the content host
2. Unregister works but throws an error in content hosts' /var/log/messages

Actual results:
May 20 17:50:18 cloud-qe-7 goferd: [INFO][worker-0] root:473 - connecting to ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647...
May 20 17:50:18 cloud-qe-7 subscription-manager: Unregistered machine with identity: 2ef50b87-dfb2-4519-adcc-92c0dcf80e28
May 20 17:50:18 cloud-qe-7 dbus-daemon: dbus[666]: [system] Activating service name='com.redhat.SubscriptionManager' (using servicehelper)
May 20 17:50:18 cloud-qe-7 dbus[666]: [system] Activating service name='com.redhat.SubscriptionManager' (using servicehelper)
May 20 17:50:19 cloud-qe-7 dbus-daemon: dbus[666]: [system] Successfully activated service 'com.redhat.SubscriptionManager'
May 20 17:50:19 cloud-qe-7 dbus[666]: [system] Successfully activated service 'com.redhat.SubscriptionManager'
May 20 17:50:19 cloud-qe-7 goferd: [INFO][Thread-3] rhsm.connection:682 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
May 20 17:50:19 cloud-qe-7 goferd: [INFO][Thread-3] rhsm.connection:693 - Connection Built: host: ibm-x3250m4-05.lab.eng.rdu2.redhat.com, port: 443, handler: /rhsm
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][Thread-3] katelloplugin:148 - send enabled report failed: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
May 20 17:50:19 cloud-qe-7 goferd: [INFO][Thread-3] katelloplugin:117 - changed: /etc/pki/consumer/cert.pem
May 20 17:50:19 cloud-qe-7 goferd: [INFO][worker-0] gofer.messaging.adapter.proton.connection:103 - connected: amqps://ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647
May 20 17:50:19 cloud-qe-7 goferd: [INFO][worker-0] gofer.rmi.dispatcher:600 - call: Consumer.unregister() sn=d38f07cc-ec0f-4424-b005-759d81d8871f data=None
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 - {u'replyto': None, u'request': {u'classname': u'Consumer', u'kws': {}, u'args': [], u'cntr': [[], {}], u'method': u'unregister'}, 'ts': 1432158618.611621, 'inbound': {'url': 'proton+amqps://ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647', 'queue': 'pulp.agent.2ef50b87-dfb2-4519-adcc-92c0dcf80e28'}, u'secret': u'555d0139361dd346181e3f16', u'version': u'2.0', u'routing': [None, u'pulp.agent.2ef50b87-dfb2-4519-adcc-92c0dcf80e28'], u'data': None, u'pam': None, u'sn': u'd38f07cc-ec0f-4424-b005-759d81d8871f'}
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 - Traceback (most recent call last):
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -   File "/usr/lib/python2.7/site-packages/gofer/rmi/dispatcher.py", line 632, in dispatch
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -     method = RMI(request, auth, self.catalog)
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -   File "/usr/lib/python2.7/site-packages/gofer/rmi/dispatcher.py", line 348, in __init__
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -     self.inst = self.find_class(request, catalog)
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -   File "/usr/lib/python2.7/site-packages/gofer/rmi/dispatcher.py", line 368, in find_class
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -     raise ClassNotFound(key)
May 20 17:50:19 cloud-qe-7 goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 - ClassNotFound: Consumer
May 20 17:50:19 cloud-qe-7 goferd: [INFO][worker-0] gofer.agent.rmi:128 - sn=d38f07cc-ec0f-4424-b005-759d81d8871f processed in: 1.214 (seconds)
May 20 17:50:28 cloud-qe-7 goferd: [WARNING][pulp.agent.2ef50b87-dfb2-4519-adcc-92c0dcf80e28] gofer.common:130 - thread:pulp.agent.2ef50b87-dfb2-4519-adcc-92c0dcf80e28, ABORTED
May 20 17:50:28 cloud-qe-7 goferd: [INFO][pulp.agent.2ef50b87-dfb2-4519-adcc-92c0dcf80e28] gofer.messaging.adapter.proton.connection:154 - closed: amqps://ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647
May 20 17:50:28 cloud-qe-7 goferd: [INFO][Thread-3] gofer.agent.plugin:333 - plugin:katelloplugin queue:pulp.agent.2ef50b87-dfb2-4519-adcc-92c0dcf80e28, detached
May 20 17:50:28 cloud-qe-7 goferd: [INFO][Thread-3] gofer.messaging.adapter.proton.connection:100 - connecting: URL: amqps://ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647|SSL: ca: /etc/rhsm/ca/katello-server-ca.pem|key: None|certificate: /etc/pki/consumer/bundle.pem|host-validation: None
May 20 17:50:28 cloud-qe-7 goferd: [INFO][Thread-3] root:473 - connecting to ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647...
May 20 17:50:28 cloud-qe-7 goferd: [INFO][Thread-3] gofer.messaging.adapter.proton.connection:103 - connected: amqps://ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647
May 20 17:50:28 cloud-qe-7 goferd: [INFO][Thread-3] root:493 - connected to ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647
May 20 17:50:29 cloud-qe-7 goferd: [INFO][Thread-3] gofer.messaging.adapter.proton.connection:154 - closed: amqps://ibm-x3250m4-05.lab.eng.rdu2.redhat.com:5647



Expected results:


Additional info:

Comment 6 Stephen Benjamin 2016-02-29 19:01:01 UTC
Created redmine issue http://projects.theforeman.org/issues/13957 from this bug

Comment 7 Bryan Kearney 2016-02-29 21:08:38 UTC
Upstream bug component is WebUI

Comment 8 Bryan Kearney 2016-03-04 15:08:49 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13957 has been closed
-------------
Anonymous
Applied in changeset commit:katello-agent|8a109d9f204531a1354f060391dcdd4368452198.

Comment 9 Roman Plevka 2016-03-21 15:29:30 UTC
VERIFIED
on: Sat 6.2 (snap #4)

#tail -f /var/log/messages

Mar 21 11:22:40 my-hostname goferd: [INFO][worker-0] gofer.messaging.adapter.proton.connection:100 - connecting: URL: amqps://my-satellite.fqdn:5647|SSL: ca: /etc/rhsm/ca/katello-default-ca.pem|key: None|certificate: /etc/pki/consumer/bundle.pem|host-validation: None
Mar 21 11:22:40 my-hostname goferd: [INFO][worker-0] root:487 - connecting to my-satellite.fqdn:5647...
Mar 21 11:22:41 my-hostname goferd: [INFO][worker-0] gofer.messaging.adapter.proton.connection:103 - connected: amqps://my-satellite.fqdn:5647
Mar 21 11:22:41 my-hostname goferd: [INFO][worker-0] gofer.rmi.dispatcher:600 - call: Consumer.unregister() sn=c21eecdc-fb16-4137-81f2-f37ec5d08c80 data=None
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 - {'replyto': None, 'request': {'classname': 'Consumer', 'kws': {}, 'args': [], 'cntr': [[], {}], 'method': 'unregister'}, 'ts': 1458573760.757596, 'inbound': {'url': 'proton+amqps://my-satellite.fqdn:5647', 'queue': 'pulp.agent.3aa28879-8400-45aa-86df-19e505651614'}, 'secret': '56f011873d5d2b4171fd95e9', 'version': '2.0', 'routing': [None, 'pulp.agent.3aa28879-8400-45aa-86df-19e505651614'], 'data': None, 'pam': None, 'sn': 'c21eecdc-fb16-4137-81f2-f37ec5d08c80'}
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 - Traceback (most recent call last):
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -   File "/usr/lib/python2.6/site-packages/gofer/rmi/dispatcher.py", line 632, in dispatch
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -     method = RMI(request, auth, self.catalog)
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -   File "/usr/lib/python2.6/site-packages/gofer/rmi/dispatcher.py", line 348, in __init__
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -     self.inst = self.find_class(request, catalog)
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -   File "/usr/lib/python2.6/site-packages/gofer/rmi/dispatcher.py", line 368, in find_class
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 -     raise ClassNotFound(key)
Mar 21 11:22:41 my-hostname goferd: [ERROR][worker-0] gofer.rmi.dispatcher:636 - ClassNotFound: Consumer
Mar 21 11:22:41 my-hostname goferd: [INFO][worker-0] gofer.agent.rmi:129 - sn=c21eecdc-fb16-4137-81f2-f37ec5d08c80 processed in: 622 (ms)

Comment 12 errata-xmlrpc 2016-07-27 08:51:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.