Bug 114843 - rc.sysinit uses /proc/bus/usb
Summary: rc.sysinit uses /proc/bus/usb
Status: CLOSED DUPLICATE of bug 118541
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-03 15:27 UTC by Sammy
Modified: 2014-03-17 02:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2004-02-03 15:27:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; , en_US, en)

Description of problem:
The rc.sysinit script wants things in /proc/bus/usb while on my
system the usb devices are in /sys/bus/usb.

I am using the rawhide 2.6.1 kernels but after recompiling them with
customized configure options for my system.

Is this a bug or is there a kernel config option that puts these into
/proc instead of /sys?

Thanks

PS: That keyboard stuff never worked for me since there is no mousedev
       and keybdev in 2.6. Hotplug does not work either, so I compile them
       in explicitly and remove all reference to these from hotplug and
       modprobe.conf.dist file to avoid error messages during boot.

Version-Release number of selected component (if applicable):
initscripts-7.46-1

How reproducible:
Always

Steps to Reproduce:
1.Install initscripts
2.look at rc.sysinit
3.
    

Additional info:

Comment 1 Bill Nottingham 2004-02-03 15:38:38 UTC
It's a bug, that whole section needs Yet Some More cleanup.

Comment 2 Leonard den Ottolander 2004-08-12 17:39:23 UTC
Hm. From bug 118541 it looks as if this is actually correct...

Are these duplicates?


Comment 3 Bill Nottingham 2004-08-12 19:13:06 UTC

*** This bug has been marked as a duplicate of 118541 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:01:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.