Bug 1148444 - logrotation fails
Summary: logrotation fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rabbitmq-server
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: John Eckersberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1197421 (view as bug list)
Depends On:
Blocks: 1252842 1267718
TreeView+ depends on / blocked
 
Reported: 2014-10-01 13:37 UTC by Jan van Eldik
Modified: 2015-10-01 11:03 UTC (History)
12 users (show)

Fixed In Version: 3.3.5-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-19 08:06:37 UTC


Attachments (Terms of Use)

Description Jan van Eldik 2014-10-01 13:37:26 UTC
Description of problem:

Logrotation fails 100% because of old-style post-rotate command

Version-Release number of selected component (if applicable):

rabbitmq-server-3.1.5-7.el7.noarch

How reproducible:

100%

Steps to Reproduce:

[root@jcentos7-01 tmp]# logrotate -f /etc/logrotate.conf
The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl.
error: error running shared postrotate script for '/var/log/rabbitmq/*.log '

[root@jcentos7-01 tmp]# cat /etc/logrotate.d/rabbitmq-server 
/var/log/rabbitmq/*.log {
        weekly
        missingok
        rotate 20
        compress
        delaycompress
        notifempty
        sharedscripts
        postrotate
            /sbin/service rabbitmq-server rotate-logs > /dev/null
        endscript
}

[root@jcentos7-01 tmp]#  /sbin/service rabbitmq-server rotate-logs > /dev/null
The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl.
[root@jcentos7-01 tmp]# echo $?
2

Comment 1 Phillip Smith 2014-11-24 00:38:33 UTC
Looking at the init script from 6, the logroate script should be updated to call:

    postrotate
       /usr/sbin/rabbitmqctl -q rotate_logs
    endscript

Comment 2 Matthias Saou 2015-01-19 13:41:25 UTC
I just bumped into this one too. It also affects the current Fedora package (3.4.3-2), and using the "/usr/sbin/rabbitmqctl -q rotate_logs" as suggested above seems to work fine, as it's silent by default.

Comment 3 Konrad Mosoń 2015-08-07 09:08:02 UTC
What about this bug? It's still here after 10 months…

Comment 4 Fedora Update System 2015-08-07 14:37:30 UTC
rabbitmq-server-3.3.5-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/rabbitmq-server-3.3.5-5.el7

Comment 5 Fedora Update System 2015-08-07 14:37:58 UTC
rabbitmq-server-3.5.4-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rabbitmq-server-3.5.4-2.fc22

Comment 6 Fedora Update System 2015-08-08 20:04:25 UTC
Package rabbitmq-server-3.3.5-5.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing rabbitmq-server-3.3.5-5.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-7568/rabbitmq-server-3.3.5-5.el7
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-08-11 18:59:05 UTC
rabbitmq-server-3.5.4-2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/rabbitmq-server-3.5.4-2.fc23

Comment 8 Fedora Update System 2015-08-19 08:06:37 UTC
rabbitmq-server-3.5.4-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-08-19 08:23:00 UTC
rabbitmq-server-3.5.4-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-09-02 05:55:13 UTC
rabbitmq-server-3.3.5-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Peter Lemenkov 2015-10-01 11:03:18 UTC
*** Bug 1197421 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.