Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1197421 - Logrotate needs to use systemctl
Summary: Logrotate needs to use systemctl
Keywords:
Status: CLOSED DUPLICATE of bug 1148444
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rabbitmq-server
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-01 04:35 UTC by Brian Wong
Modified: 2015-10-01 11:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-01 11:03:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Brian Wong 2015-03-01 04:35:45 UTC
Description of problem:
The package rabbitmq-server-3.3.5-4.el7.noarch installs a logrotate configuration file that uses /sbin/service. Log rotation does not run successfully because the postrotate parameter needs to be updated.

The message received from logrotate (via cron):
/etc/cron.hourly/logrotate:

The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl.
error: error running shared postrotate script for '/var/log/rabbitmq/*.log '

Version-Release number of selected component (if applicable):
rabbitmq-server-3.3.5-4.el7.noarch

How reproducible:
Consistently

Steps to Reproduce:
1. Install rabbitmq-server.
2. View logrotate configuration file /etc/logrotate.d/rabbitmq-server
3.

Actual results:
All I can confirm is the error message from logrotate, whether the rabbitmq logs actually get rotated, I cannot say for sure at this time.

Expected results:
A working postrotate command

Additional info:

Comment 1 Peter Lemenkov 2015-10-01 11:03:18 UTC

*** This bug has been marked as a duplicate of bug 1148444 ***


Note You need to log in before you can comment on or make changes to this bug.