Bug 114857 - xmms wont build without xmms-devel installed
xmms wont build without xmms-devel installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 115527 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 11:54 EST by rob
Modified: 2014-03-16 22:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 22:26:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rob 2004-02-03 11:54:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
if XMMS_CONFIG is not set to xmms-config in the xmms build tree, or if
xmms-devel is not installed xmms fails to build.

Version-Release number of selected component (if applicable):
xmms-1.2.9-1.p xmms-1.2.9-2.p

How reproducible:
Always

Steps to Reproduce:
1. make sure xmms-devel is _not_ installed
2. rpmbuild -ba xmms.spec
3. build fails

Actual Results:  Error is:
*** The xmms-config script installed by XMMS could not be found.
*** If XMMS was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the XMMS_CONFIG environment variable to the
*** full path to xmms-config.
configure: error: *** XMMS >= 1.0.0 not installed - please install
first ***


Expected Results:  a successful build

Additional info:

i'm not sure this is the most elegant way to do it, but it works for me:

--- xmms.spec.orig      2004-02-03 11:48:12.000000000 -0500
+++ xmms.spec   2004-02-03 11:49:42.000000000 -0500
@@ -85,6 +85,7 @@
 %patch10 -p0 -b .buffer
  
 %build
+export XMMS_CONFIG=`pwd`/xmms-config
 %configure --enable-kanji --enable-texthack --enable-arts-shared \
   --enable-ipv6
 make
Comment 1 Bill Nottingham 2004-02-13 15:36:44 EST
*** Bug 115527 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-03-11 22:26:22 EST
Fixed in 1.2.10-1.

Note You need to log in before you can comment on or make changes to this bug.