Bug 115527 - xmms build depends on xmms-devel
Summary: xmms build depends on xmms-devel
Status: CLOSED DUPLICATE of bug 114857
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 09:50 UTC by Noa Resare
Modified: 2014-03-17 02:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noa Resare 2004-02-13 09:50:45 UTC
Description of problem:

Since the inclusion of arts_output xmms needs xmms-devel to be
installed to build. Otherwise the configure script in arts_output
fails when it tries to find the xmms-config binary.

A simple fix could be to include xmms-devel in the build dependencies,
but since this is an (unneccesary) circular dependency I would suggest
instead patching the arts_output configure script not to look for xmms
since it per definition should exist :)

Version-Release number of selected component (if applicable):
xmms-1.2.9-2.p

How reproducible:
always

Steps to Reproduce:
1. try to build with 'rpmbuild -bb xmms.spec' without xmms-devel installed

Comment 1 Noa Resare 2004-02-13 09:57:16 UTC
Another missing build dependency while you're at it is glib2-devel

Comment 2 Bill Nottingham 2004-02-13 20:36:42 UTC

*** This bug has been marked as a duplicate of 114857 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:01:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.