Bug 114867 - ISDN Dial on Demand, no default route after ifdown, some other problems with default route
ISDN Dial on Demand, no default route after ifdown, some other problems with ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: isdn4k-utils (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 14:04 EST by Uwe Beck
Modified: 2015-01-07 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 14:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2004-02-03 14:04:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030922

Description of problem:
I create my ISDN provider by name "brickxmp" with Dial on Demand.

/etc/sysconfig/network-scripts
ifcfg-eth0
ifcfg-eth1
ifcfg-brickxmp <-- ifcfg-ippp0 before the new program version (see Bug
91607)

After the system was rebooted:

netstat -r
Kernel IP Routentabelle
Ziel            Router    Genmask       Flags   MSS Fenster irtt Iface
172.16.39.0     *       255.255.255.0   U         0 0          0 eth0
172.16.38.0     *       255.255.255.0   U         0 0          0 ippp0
172.16.37.0     *       255.255.255.0   U         0 0          0 eth1
169.254.0.0     *       255.255.0.0     U         0 0          0 eth1
127.0.0.0       *       255.0.0.0       U         0 0          0 lo
default   172.16.39.81  0.0.0.0         UG        0 0          0 eth0

The ifcfg-eth0 contains the parameter GATEWAY=172.16.39.81.
The default route is set over eth0, but should be set over ippp0.
Before this version of redhat-config-network the ISDN-interface name
was always ippp0. This mistake comes from the loop in the if-up script
and it was a random that I have found this mistake because my
providername is "brickxmp".

Next problem.
Now correct the default route with:
- ifdown brickxmp
- ifup brickxmp

netstat -r
Kernel IP Routentabelle
Ziel            Router    Genmask       Flags   MSS Fenster irtt Iface
172.16.39.0     *       255.255.255.0   U         0 0          0 eth0
172.16.38.0     *       255.255.255.0   U         0 0          0 ippp0
172.16.37.0     *       255.255.255.0   U         0 0          0 eth1
169.254.0.0     *       255.255.0.0     U         0 0          0 eth1
127.0.0.0       *       255.0.0.0       U         0 0          0 lo
default    172.16.38.1  0.0.0.0         UG        0 0          0 ippp0

After timeout ISDN the default route will not set new. 

Rename ifcfg-brickxmp into ifcfg-ippp0.

mv ifcfg-brickxmp ifcfg-ippp0

The ISDN default route will set now after timeout ISDN. It works
correct again. I do not found, where the mistake in the scripts is.

kisdndock is not in RHEL3, but I know, that this progamm can only work
with the /etc/sysconfig/network-scripts/ifcfg-ipppx configfiles.
To show the name of ISDN providers, kisdndock use the option
PROVIDER=brickxmp in the ifcfg-ippp0.
With /etc/sysconfig/network-scripts/ifcfg-brickxmp the kisdndock do
not goes in the o.k. status (color gray) on the KDE desktop.

The new convention for ISDN config filename is inconsequent.

Also I see an other problem. Today it is a requirement, that you can
define the order in which the interface comes up at boot time. All
interfaces should be able to set the default route, if it is necessary.

One order could be:
lo -> ethx -> trx -> ipppx -> pppx
This is an order were I think it is suggestive. Today your internet
provider is over ADSL mostly, but if not, the ppp0 interface do not
exist and ISDN is the default route. If you do not have a internet
provider the LAN default route will be set. I think this can be a way
for this problem.


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.59-1, initscripts-7.31.9.EL-1

How reproducible:
Always

Steps to Reproduce:
1.configure ISDN and use a providename begins with a-d
2.reboot the system
3.
    

Actual Results:  - ISDN routing do not work correct
- no default route after hangup  

Expected Results:  should be work correct

Additional info:
Comment 1 Harald Hoyer 2004-02-04 06:02:48 EST
why do you set GATEWAY=172.16.39.81 anyway? where does that gateway
lead to? to other internal networks? maybe a static route with
network 172.16.0.0 gateway 172.16.39.81
would be better? default gateways should lead to every other ip address.
Comment 2 Uwe Beck 2004-02-04 09:20:31 EST
I use normaly an other system with other ip-addresses. Yesterday I
create this Bugilla Bug on a system at work.
There the GATEWAY=172.16.39.81 is realy a default gateway.

For ISDN the ethernet configuration on the system is:

DEVICE=eth0
BOOTPROTO=none
HWADDR=00:50:04:42:57:FD
IPADDR=128.0.5.12
NETMASK=255.255.255.0
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=no
GATEWAY=128.0.5.9

And so the default route at ippp0 is o.k..

Sorry for this mistake.
Comment 3 Uwe Beck 2004-03-16 09:49:21 EST
No default route after hangup, also with
redhat-config-network-1.2.60-1.noarch.rpm.

I must move the config file, that the default route is set after
hangup. You see the problem, if you use static ip adresses and Dial on
Demand.
mv ifcfg-brickxmp ifcfg-ippp0
Only, if the config file is named ifcfg-ippp0 (for the first provider)
it works.
The name of the config file is generated from the tool and the
providername is internal the nickname in the tool!
Comment 4 Ngo Than 2004-03-22 16:39:44 EST
it looks like a bug in initscript.
Comment 5 Ngo Than 2004-04-07 06:55:49 EDT
i think it's a bug in your eth0 network setting that includes the
default route too (GATEWAY=128.0.5.9). It will delete the ISDN default
route!

please remove the GATEWAYE line in your network config file
ifcfg-eth0, it will fix your problem.
Comment 6 Uwe Beck 2004-04-07 14:12:09 EDT
Yes, it works correct without the GATEWAY in eth0 network setting. I
must remove the GATEWAY in eth0 network setting after kickstart
installation by hand.

So we need a feature request for initscript.

You can close this bug.

Note You need to log in before you can comment on or make changes to this bug.