Bug 114887 - RFE: zsh configuration
RFE: zsh configuration
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
http://isd.usc.edu/~ehatteme/zsh/zsh-...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 19:31 EST by Eric Hattemer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 12:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zsh etc files (1.83 KB, application/x-tar)
2004-02-03 19:34 EST, Eric Hattemer
no flags Details

  None (edit)
Description Eric Hattemer 2004-02-03 19:31:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20030208 Netscape/7.02

Description of problem:
http://isd.usc.edu/~ehatteme/zsh/zsh-etc-1-30-01PST.tar.bz2

is an archive that decompresses to ./etc/z* and includes all of the
zsh configuration files.  The only one that has been modified is
zshrc.  I added some keybindings, set the prompt, turned on
auto-completion, and made some other customizations.  It is now more
similar to the mandrake version of zsh.  Please review the changes.  I
don't expect you to add this as is, but please consider the changes as
suggestions.  I can't guarantee all the changes were made to the right
files.  I would expect zsh is almost entirely used as an interactive
shell, though.  I've never seen
#!/bin/zsh
in a script.  I think the main drawing/selling point of zsh is its
advanced features, so that's why I tried to turn as many as possible on.  

Version-Release number of selected component (if applicable):
4.1.1 or others

How reproducible:
Always

Steps to Reproduce:
not relevant

Additional info:

to check out these files:
su -
cd /etc
mkdir ~/zshbackup
cp z* ~/zshbackup
cd 
mkdir zsh-etc
cd zsh-etc
tar xvjf $downloads/zsh-etc-1-30-01PST.tar.bz2
cp ** /etc/
Comment 1 Eric Hattemer 2004-02-03 19:34:52 EST
Created attachment 97449 [details]
zsh etc files
Comment 2 Eric Hattemer 2004-02-03 20:05:13 EST
I made a page to try to straighten out exactly what gets read and
when.  It is at http://isd.usc.edu/~ehatteme/zsh/environment.html

Assuming zsh doesn't require any of the changes to run a script, and
that there isn't serious need to differentiate between login and
interactive shells, it seems fair to put everything into /etc/zshrc.  

When /etc/profile gets sourced is still in question, though.  I don't
personally agree with the .zshrc file, because /etc/profile contains
some important things, and rpm -i zsh* will not add that file to user
directories, right?
Comment 3 Jens Petersen 2004-04-11 20:33:11 EDT
Thanks for sending in your zsh configs.
Some of it looks really nice and useful.
Some I'm too conservation to enable by default
but have included it in .zshrc commented.
And some I'm not sure about, I've left out for now.
Feel free to describe some of the stuff I may have missed
in more detail and why you feel it should be included in
a default configuration, and we can try to experiment
and see how it goes.  System defaults have to be conservation
but there is more room for adventure in the dotzshrc file.

It just occured to me though that what would be really nice
would be a complete config file listing all the env variables
and options and their defaults and possible values say.  That
would be an extremely useful reference and allow users to easily
add cool stuff that they want into their rc files, without forcing
it upon every zsh user.  Some people like to KISS. :)

Changes initial changes should appear in zsh-4.2.0-1.
Comment 4 Alan Cox 2004-06-16 12:03:44 EDT
Verified in zsh-4.2.0-1

Note You need to log in before you can comment on or make changes to this bug.