Bug 1148914 - [abrt] python-boto: auth.py:883:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['QuerySignatureV2AuthHandler'] Check your credentials
Summary: [abrt] python-boto: auth.py:883:get_auth_handler:NoAuthHandlerFound: No handl...
Status: CLOSED DUPLICATE of bug 821799
Alias: None
Product: Fedora
Classification: Fedora
Component: python-boto   
(Show other bugs)
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Garrett Holmstrom
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:4e05b7452095cc0774722607d8c...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-02 16:04 UTC by upendar
Modified: 2016-08-11 05:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-07 19:53:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.63 KB, text/plain)
2014-10-02 16:04 UTC, upendar
no flags Details
File: environ (2.23 KB, text/plain)
2014-10-02 16:04 UTC, upendar
no flags Details

Description upendar 2014-10-02 16:04:45 UTC
Version-Release number of selected component:
python-boto-2.27.0-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /bin/list_instances
executable:     /bin/list_instances
kernel:         3.15.10-201.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
auth.py:883:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['QuerySignatureV2AuthHandler'] Check your credentials

Traceback (most recent call last):
  File "/bin/list_instances", line 90, in <module>
    main()
  File "/bin/list_instances", line 50, in main
    ec2 = boto.connect_ec2(region=region)
  File "/usr/lib/python2.7/site-packages/boto/__init__.py", line 170, in connect_ec2
    return EC2Connection(aws_access_key_id, aws_secret_access_key, **kwargs)
  File "/usr/lib/python2.7/site-packages/boto/ec2/connection.py", line 102, in __init__
    profile_name=profile_name)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 1073, in __init__
    profile_name=profile_name)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 572, in __init__
    host, config, self.provider, self._required_auth_capability())
  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 883, in get_auth_handler
    'Check your credentials' % (len(names), str(names)))
NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['QuerySignatureV2AuthHandler'] Check your credentials

Local variables in innermost frame:
total_handlers: 1
checked_handlers: [<class 'boto.auth.QuerySignatureV2AuthHandler'>]
provider: <boto.provider.Provider object at 0x206cfd0>
host: u'ec2.us-east-1.amazonaws.com'
handler: <class 'boto.auth.QuerySignatureV2AuthHandler'>
names: ['QuerySignatureV2AuthHandler']
ready_handlers: []
requested_capability: ['ec2']
auth_handlers: [<class 'boto.auth.QuerySignatureV2AuthHandler'>]
config: <boto.pyami.config.Config instance at 0x1d674d0>

Comment 1 upendar 2014-10-02 16:04:49 UTC
Created attachment 943451 [details]
File: backtrace

Comment 2 upendar 2014-10-02 16:04:50 UTC
Created attachment 943452 [details]
File: environ

Comment 3 Garrett Holmstrom 2014-11-07 19:53:30 UTC

*** This bug has been marked as a duplicate of bug 821799 ***


Note You need to log in before you can comment on or make changes to this bug.