Bug 114914 - xrandr gives peculiar results on a trident cyberblade.
xrandr gives peculiar results on a trident cyberblade.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 09:13 EST by Telsa Gwynne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 07:25:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2004-02-04 09:13:03 EST
Description of problem:

When playing with xrandr -s and the available screen sizes, I
found that switching from one particular one to another resulted
in a messed up screen: it was as though it drew the whole thing
onto the left-hand half of the screen and then repeated a section
of that several times to the right. So that if I moved my mouse 
over to the right, I would see several cursors moving in sync.

Switching to a virtual text console and back cures it. Switching
to a different size as an intermittent stage stops it happening.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42.

How reproducible: every time on this machine. 

$ xrandr
 SZ:    Pixels          Physical       Refresh
*0   1280 x 1024   ( 342mm x 271mm )  *60
 1   1280 x 960    ( 342mm x 271mm )   60
 2   1152 x 864    ( 342mm x 271mm )   75
 3   1024 x 768    ( 342mm x 271mm )   75   70   60
 4    800 x 600    ( 342mm x 271mm )   75   72   60   56
 5    640 x 480    ( 342mm x 271mm )   75   72   60
 6   1152 x 768    ( 342mm x 271mm )   54
 7    832 x 624    ( 342mm x 271mm )   74
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none
$ xrandr -s 5
$ randr -s 0

That's it. Does it every time for me. Going from 1 to 0 does not cause it.
I can play around with more "if I go from here to here to here"
combinations
if it helps. 5 is fine, incidentally. It's the move from 5 to 0 which
messes
it up. 

Monitor is a Dell LCD which does up to 1280x1024. 
Video card is a Trident CyberBlade.
Comment 1 John Eckerdal 2004-03-20 10:13:13 EST
I have seen this problem also.

In my case it was switching from 1024x768 to 640x480 that messed up 
the screen. The problem remained even when I switched back to 
1024x768 but now there were several "stripes" with repeated content.

Like so:
1. Screen from (0,0)-(127,768)
2. Black area from (128,0)-(255,768)
3. Screen from (256,0)-(383,768) [same contents as in 1]
2. Black area from (384,0)-(512,768)

I am not sure about 128, 256, 384, 512 limits. These are just 
estimated values (and easier to count with).
Comment 2 John Eckerdal 2004-05-08 19:41:38 EDT
With the new xorg release available (xorg-x11-6.7.0-2) I can no 
longer reproduce the problem. I've tried changing resolutions back 
and forth between the available resolutiuons without noticing any 
problems.
Comment 3 Mike A. Harris 2004-05-10 01:54:11 EDT
This could be related to bug #120950 perhaps.  That's the only thing
that's changed that might affect this that I can think of off the
top of my head.

Telsa, can you test the current FC2 bits and let me know if this issue
is still reproduceable, or wether it's resolved now?

Thanks in advance,
TTYL
Comment 4 Mike A. Harris 2004-09-21 07:25:08 EDT
Assuming the problem is fixed now for everyone in Fedora Core 2,
as per comment #2 above.  Please reopen if problem returns.

Thanks again.

Setting status to "CURRENTRELEASE" of FC2.

Note You need to log in before you can comment on or make changes to this bug.