Bug 1149262 - getVdsHardwareInfo incomplete for IBM Power 8
Summary: getVdsHardwareInfo incomplete for IBM Power 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.6.0
Hardware: ppc64le
OS: Unspecified
unspecified
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Polednik
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks: 1122979 RHEV3.6PPC
TreeView+ depends on / blocked
 
Reported: 2014-10-03 15:41 UTC by Jiri Belka
Modified: 2016-03-09 19:25 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.6.0-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 19:25:43 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 33857 master MERGED caps: Additional ppc64 hardware information Never
oVirt gerrit 34617 ovirt-3.5 MERGED caps: Additional ppc64 hardware information Never
oVirt gerrit 43824 master MERGED caps: add hw info reporting for ppc64le arch Never

Description Jiri Belka 2014-10-03 15:41:26 UTC
Description of problem:
ibm power8

# vdsClient -s 0 getVdsHardwareInfo
        systemFamily = 'PowerNV'
        systemManufacturer = 'unavailable'
        systemProductName = 'unavailable'
        systemSerialNumber = '8247-22L'
        systemUUID = '2116A5A'
        systemVersion = 'PowerNV 8247-22L'

vs

intel del r210ii

# vdsClient -s 0 getVdsHardwareInfo
        systemManufacturer = 'Dell Inc.'
        systemProductName = 'PowerEdge R210 II'
        systemSerialNumber = '34SRJ5J'
        systemUUID = '4C4C4544-0034-5310-8052-B3C04F4A354A'

IIRC IBM did not sell Pseries to Lenovo yet, so Manufacturer is still IBM :D

Version-Release number of selected component (if applicable):
vdsm-4.14.17-1.mrkev.ppc64

How reproducible:
100%

Steps to Reproduce:
1. get getVdsHardwareInfo output
2.
3.

Actual results:
missing data

Expected results:
all data

Additional info:

Comment 1 Yaniv Bronhaim 2014-10-05 14:01:32 UTC
Jiri, I don't understand what field is missing. please attach your full dmidecode --system output and let me know exactly what field do you think that is missing here. afair vdsm returns all the dmidecode output, expect those who aren't provided by dmidecode, or specified as UNKNOWN.

Comment 2 Jiri Belka 2014-10-05 14:34:39 UTC
there's no dmidecode for ppc64 platform.

Comment 3 Yaniv Bronhaim 2014-10-05 16:01:53 UTC
Jiri, sorry,. totally forgot about the initial work - we have ppc64HardwareInfo.py which I prefer to leave to Vitor to take a look 

Vitor, can you share your thoughts ?

Comment 4 Michal Skrivanek 2014-10-06 08:02:57 UTC
These values are pulled from "system" table of x86 BIOS so it's not applicable to pseries. I would close NOTABUG

Comment 5 Jiri Belka 2014-10-06 08:26:48 UTC
What? Then you should get it in other way, virtualization doesn't exist only on buggy x86 platform.

Comment 6 Jiri Belka 2014-10-06 08:34:54 UTC
FYI on AIX one can to `uname -M' and `prtconf' to get some hw details.

systemSerialNumber = '8247-22L'
                      ^^^^^^^^ but model version

Comment 7 Vitor de Lima 2014-10-08 14:15:34 UTC
The proposed patch fixes this issue.

Comment 8 Lukas Svaty 2014-11-11 13:12:11 UTC
we need this build from ibm for 3.5 for this reason moving back to ASSIGNED

Comment 9 Jiri Belka 2014-11-25 09:58:32 UTC
checking via restapi / 3.4.4:

        <hardware_information>
            <manufacturer>Dell Inc.</manufacturer>
            <serial_number>BX4X85J</serial_number>
            <product_name>PowerEdge R210 II</product_name>
            <uuid>4C4C4544-0058-3410-8058-C2C04F38354A</uuid>
        </hardware_information>

        <hardware_information>
            <manufacturer>unavailable</manufacturer>
            ^^^^^^^^^^^^^^ lshw shows IBM as vendor
            <version>PowerNV 8247-22L</version>
            <serial_number>8247-22L</serial_number>
             ^^^^^^^^^^^^^^ serial: 211DA9A
            <product_name>unavailable</product_name>
             ^^^^^^^^^^^^^ model: lshw - IBM Power System S822L ??
             Model Name: 8247-22L

            <uuid>211DAAA</uuid>
            ^^^^^^ ??
            <family>PowerNV</family>
        </hardware_information>

it would be also nice to see firmware:

[root@ibm-p8-rhevm-02 ~]# lscfg -v | sed -n '/firmware/,$p'
  firmware                               System Firmware                       
        Microcode Level.(ML)......FW810.10 FW810.10 FW810.10
        Firmware.(CL).............OPAL v3 5037623

[root@ibm-p8-rhevm-02 ~]# lsmcode 
Version of System Firmware is FW810.10 (SV810_081) (t) FW810.10 (SV810_081) (p) FW810.10 (SV810_081) (b)

Comment 10 Michal Skrivanek 2014-11-25 13:35:49 UTC
the bug is fixed in 3.5, so where did you test it?

for the additional fw - open a standalone bug. it wasn't asked for in the original description.

as for the build availability - you can use the upstream oVirt 3.5 version to verify...

Comment 11 Jiri Belka 2014-11-25 13:50:23 UTC
this should be backported imo, 3.4.4 is still wrong

Comment 12 Michal Skrivanek 2014-11-25 13:53:04 UTC
(In reply to Jiri Belka from comment #11)
> this should be backported imo, 3.4.4 is still wrong

request an exception on program call then, but the likelihood is pretty low;-)

Comment 15 Artyom 2015-05-03 13:23:40 UTC
Wait for 3.6 RHEL7.2 ppc build

Comment 18 Artyom 2015-07-12 15:17:11 UTC
Checked on vdsm-4.17.0.8-1.el7ev.noarch
vdsClient -s 0 getVdsHardwareInfo
return nothing

Comment 19 Michal Skrivanek 2015-07-20 07:00:08 UTC
additionally, getVdsStats raises exception

Thread-56393::ERROR::2015-07-20 10:38:32,207::bindingxmlrpc::1265::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/rpc/bindingxmlrpc.py", line 1249, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/rpc/bindingxmlrpc.py", line 527, in getStats
    return api.getStats()
  File "/usr/share/vdsm/API.py", line 1354, in getStats
    decStats = self._cif._hostStats.get()
  File "/usr/share/vdsm/virt/sampling.py", line 652, in get
    stats['cpuStatistics'] = self._getCpuCoresStats()
  File "/usr/share/vdsm/virt/sampling.py", line 672, in _getCpuCoresStats
    jiffies = (hs1.cpuCores.getCoreSample(cpuCore)['user'] -
TypeError: 'NoneType' object has no attribute '__getitem__'

Comment 20 Michal Skrivanek 2015-07-20 12:28:38 UTC
err from last comment doesn't reproduce on master

Comment 21 Artyom 2015-08-12 13:35:30 UTC
Verified on vdsm-4.17.2-1.el7ev.noarch
vdsClient -s 0 getVdsHardwareInfo
        systemFamily = 'PowerNV'
        systemManufacturer = 'IBM'
        systemProductName = 'IBM Power System S824'
        systemSerialNumber = '8286-42A'
        systemUUID = '217217V'
        systemVersion = 'PowerNV 8286-42A'

Comment 23 errata-xmlrpc 2016-03-09 19:25:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.