Bug 1149265 - Main menu bar appears on top of Favorites menu in IE
Summary: Main menu bar appears on top of Favorites menu in IE
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER05
: JON 3.3.0
Assignee: Jay Shaughnessy
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-03 15:50 UTC by Libor Zoubek
Modified: 2015-11-02 00:44 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:04:43 UTC


Attachments (Terms of Use)
screenshot (367.23 KB, image/png)
2014-10-03 15:50 UTC, Libor Zoubek
no flags Details
favorites_menu (63.93 KB, image/png)
2014-10-23 08:33 UTC, Armine Hovsepyan
no flags Details

Description Libor Zoubek 2014-10-03 15:50:26 UTC
Created attachment 943755 [details]
screenshot

Description of problem:


Version-Release number of selected component (if applicable):
JON 3.3.0

How reproducible: always

Steps to Reproduce:
1. open in IE 11
2. click on Favorites button
3.

Actual results: menu expanded by favorites appears under main menubar


Expected results: menu must appear on top


Additional info:

Comment 1 Jay Shaughnessy 2014-10-10 22:07:12 UTC
I actually tried to workaround this for a few hours with no luck.  The best workaround I have is to move it below the menubar.  I just can't seem to find a way to get the smartgwt widget to display on top of the native js (htmlflow) linkbar.

Some better js guru will need to figure this out.  Or, if you want my workaround let me know.

Comment 2 Libor Zoubek 2014-10-11 19:20:11 UTC
Jirka recently added some giga css selector that was fixing different issue with notification being on top of User menu items. His selector somehow affects favourites view in IE, I guess he's the right guru.

Comment 3 Jay Shaughnessy 2014-10-13 20:50:38 UTC
Still trying my hand at this, trying to take into consideration Jirka's changes.  Assigning to me for now...

Comment 4 Jay Shaughnessy 2014-10-14 02:34:35 UTC
Jirka, created https://github.com/rhq-project/rhq/pull/137.

This looks to be working.  I tried a little to do things in css but I don't know it very well, so I ended up not doing that and just trying to let it defer to your existing css changes.  Please review.  Feel free to merge if it's OK, otherwise I'll follow up with any comments.  Thanks, Jay

Comment 5 Jirka Kremser 2014-10-14 23:00:50 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/214dd7c9e
time:    2014-10-15 00:52:55 +0200
commit:  214dd7c9e20e60dd1aefd86db0efe85a0cc5bcb3
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1149265] - Main menu bar appears on top of Favorites menu in IE -
         bringing favorites menu into foreground (by resetting the
         z-index to all it's parrents and setting it's z-index to a high
         value, all in CSS)


Jay, I've fixed that using the CSS only and without breaking bug 1144052. However, something from your PR will be needed anyway, namely:

* Remove the '#' href from the current user dropdown
* I18N issue 
 ...and perhaps also
* Delete class FavoritesButton (not used)

I'll merge those ^ parts from your PR manually tomorrow, if you are ok with that.

Comment 6 Jirka Kremser 2014-10-15 12:31:56 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/69e5645c0
time:    2014-10-15 14:12:29 +0200
commit:  69e5645c04426f6177c870b3a70e13721bed48d6
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1149265] - Main menu bar appears on top of Favorites menu in IE -
         Incorporating the changes from Jay's pr #137. I.e. I18n, Remove
         the '#' href from the current user dropdown

Comment 7 Jay Shaughnessy 2014-10-15 19:59:59 UTC
Jirka, I built master and the problem is not solved for me, it's the same as reported. I'm on IE11.  Lets discuss tomorrow, I can share my screen if you like, if you want to inspect the DOM.  I do see the I18N and href fixes, and the deployed CSS look like it contains your changes.

Comment 8 Jirka Kremser 2014-10-16 13:53:14 UTC
I must have missed that, here is the fix (tested on IE11)

branch:  master
link:    https://github.com/rhq-project/rhq/commit/7c6a0916d
time:    2014-10-16 15:52:18 +0200
commit:  7c6a0916dd2bc1899215336423926287b0805556
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1149265] - Main menu bar appears on top of Favorites menu in IE -
         z-index++

Comment 9 Jay Shaughnessy 2014-10-16 22:32:15 UTC
Jirka,  unfortunately this fixed the favs menu but the message bar no longer appeared.  My attempts to solve that problem didn't go very well, so I changed direction.

What I've done is pushed another commit to the PR branch. It solves all of the issues but partly because I changed some GUI behavior.  Like my original commit it adds no new IE-specific CSS, it removes hardcoded z-index setting from MenuBarView, deferring to the 'auto' settings you already placed in the CSS. And it uses the simpler FavoritesMenu as opposed to FavoritesButton.  But it simplifies my earlier stuff by using an explicit z-index for message bar. Furthermore, it eliminates the whole headache of the favs/user dropdown interactions with the message bar by just clearing the message bar if the user clicks on either dropdown.  That seems fine to me, in fact I like it better.  It's cleaner looking and I doubt the user needs to read the message further if he's trying to click on the menus.

If you're OK with this we can just merge the PR branch. If you'd prefer to refine the CSS solution go ahead and I can test your next revision, but it would be nice to be done with this asap as the ER05 cutoff is tomorrow.  I'll catch up with you tomorrow...

Comment 10 Jirka Kremser 2014-10-17 13:57:24 UTC
+1 

I like it better, let's merge your PR.

Comment 11 Jay Shaughnessy 2014-10-17 18:09:21 UTC
master commit a0db8e60c0e79334793cb014e5837440a1fbc7b4
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Fri Oct 17 14:00:12 2014 -0400

    This commit in effect reverts the CSS changes but keeps the fixes to I18N
    and the user menu href.  Additionally:
    - Remove FavoritesButton as that button was no longer used, and replace
      with FavoritesMenu.
    - Remove some explicit zIndex settings and defer to the css defs in
      play due to the recent work for BZ 1144052.  Keep explicit zIndex for
      the MessageBar to ensure it gets precedence.
    - Simplify menu bar interactions by clearing the message bar if the favs
      or user dropdowns are clicked on.


release/jon3.3.x commit 13e260a6f0b2f922800f69df78f7aecdad321560
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Fri Oct 17 14:07:56 2014 -0400

    (cherry picked from commit a0db8e60c0e79334793cb014e5837440a1fbc7b4)
    Conflicts:        modules/enterprise/gui/coregui/src/main/java/org/rhq/coregui/client/menu/MenuBarView.java
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 12 Simeon Pinder 2014-10-21 20:24:17 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 13 Armine Hovsepyan 2014-10-23 08:33:24 UTC
Created attachment 949740 [details]
favorites_menu

Comment 14 Armine Hovsepyan 2014-10-23 08:34:28 UTC
verified in JON 3.3 ER05 + IE11


Note You need to log in before you can comment on or make changes to this bug.