Bug 114929 - to be installed package list doesn't reflect what's in ks.cfg
Summary: to be installed package list doesn't reflect what's in ks.cfg
Status: CLOSED DUPLICATE of bug 151769
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-04 16:52 UTC by Xavier Bachelot
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 23:41:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Xavier Bachelot 2004-02-04 16:52:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When doing a kickstart install in interactive mode, the "Package Group
Selection" page does reflect what's in the ks.cfg for the group
selection, but does not reflect all "tuning" in this file

For example, if ks.cfg contains :
 @ sql-server
-perl-DBD-Pg
mysql-server
-postgresql-server
-postgresql

and you click on details in the "SQL Database Server" section, the
selection shown will still be the default one (perl-DBD-Pg ;
postsgresql-server ; unixODBC)
It should show : mysql-server ; unixODBC. 

Nevertheless, the resulting install will contains the packages
selected in ks.cfg. 

Version-Release number of selected component (if applicable):
anaconda-9.2-2

How reproducible:
Always

Steps to Reproduce:
1.Install a Fedora Core 1 box with kickstart in interactive mode,
providing a fine tuned ks.cfg 
2.At package group selection page, go to details in a section not
using the default preset of packages
3.
    

Actual Results:  The modifications on preselected packages groups are
not shown

Expected Results:  The modifications on preset packages groups are
done according to what's in the ks.cfg file

Additional info:

Comment 1 Paul Nasrat 2005-11-28 23:41:34 UTC
Collapse to single bug

*** This bug has been marked as a duplicate of 151769 ***


Note You need to log in before you can comment on or make changes to this bug.