Bug 11497 - Bad TeX output (double-hyphens)
Bad TeX output (double-hyphens)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openjade (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://people.redhat.com/twaugh/docbo...
:
: 21831 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-18 04:23 EDT by Tim Waugh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-15 13:32:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2000-05-18 04:23:58 EDT
The following produces an ndash rather than two hyphens, using db2ps:

<!DOCTYPE para PUBLIC "-//OASIS//DTD DocBook V3.1//EN"[]>
<para>
 <programlisting>
  <![CDATA[count--;]]>
 </programlisting>
</para>

The work-around that I'm using is this:

<!DOCTYPE para PUBLIC "-//OASIS//DTD DocBook V3.1//EN"[]>
<para>
 <programlisting>
  <![CDATA[count]]>&mdash;<![CDATA[;]]>
 </programlisting>
</para>

(Obviously it can be done more simply for this small example)

This is a bug in jade since it puts '--' in the TeX output, which of course
is TeX speak for ndash.  It doesn't seem reasonable to do this when in
<programlisting><![CDATA[[...]]></> tags. (I don't fully understand why
&mdash; comes out as two dashes rather than an mdash, either, but at least
it gives me a work-around..)
Comment 1 Tim Waugh 2000-12-08 10:00:52 EST
*** Bug 21831 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2001-06-20 06:39:04 EDT
Fixed in openjade-1.3-17.

Note You need to log in before you can comment on or make changes to this bug.