Bug 21831 - Small problems with "--", "---", missing DOCTYPE in generated HTML
Summary: Small problems with "--", "---", missing DOCTYPE in generated HTML
Status: CLOSED DUPLICATE of bug 11497
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: docbook   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-06 22:28 UTC by vigna
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 20:44:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vigna 2000-12-06 22:28:35 UTC
Three small problems with the SGML tools for DocBook:

1) if "--" or "---" is present in the text (in my case I was quoting the
--termname option of gnome-terminal) the print style sheet emits "--" and
"---" in the TeX source, but TeX converts them to an en-dash and to an
em-dash, respectively. The style sheet (or jade, or whoever is to blame for
this) should emit "-{}-" and "-{}-{}-".

2) There is no DOCTYPE at the start of the HTML pages generated (OK, I
realize few people 
puts it, but since this is an SGML tool... 8^).

3) Sometimes a P element is closed without having been opened. Just try
compile by Backspace-Delete Mini-HowTo (on www.linuxdoc.org). I suspect
this happens very frequently. I checked with the W3C validator and that's
all it complains about (well, OK, there's also the missing DOCTYPE).

                                                                seba

Comment 1 Tim Waugh 2000-12-07 10:22:30 UTC
For the first issue, see bug 11497 (which applies to openjade too).

For the others: exactly which tools are you using?  openjade directly, the
db2xxx ones in stylesheets, or the sgml-tools ones?

Comment 2 vigna 2000-12-07 20:37:12 UTC
I am using openjade directly with

jade -d /usr/lib/sgml/stylesheets/nwalsh-modular/html/docbook.dsl -t sgml
bsdel.sgml

Using db2html the third problem is less frequent (but still present). In the
case of my mini-HOWTO, it happens just in the x.html generated file. The missing
DOCTYPE problem is still there.

I can't use sgml-tools, I just installed 7.0 and sgml2html just gives

/usr/bin/sgmlsasp: can't open `/usr/lib/sgml-tools/dist/aclass': No such file or
directory

BTW: bug 11497 is several months old. Is no one planning a fix?


Comment 3 Tim Waugh 2000-12-08 15:00:55 UTC
It's been reported to the openjade people but I haven't heard anything back.  I
don't think it's too hard to fix though.

I'm closing this as duplicate.  For the second and third issues, see bug 21941
and bug 21944.  Feel free to CC yourself on them.


*** This bug has been marked as a duplicate of 11497 ***


Note You need to log in before you can comment on or make changes to this bug.