Bug 1149782 - liveusb-creator creates non-booting Live USB
Summary: liveusb-creator creates non-booting Live USB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-06 15:41 UTC by satellitgo
Modified: 2016-09-20 02:46 UTC (History)
10 users (show)

Fixed In Version: liveusb-creator-3.13.2-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-06 10:16:33 UTC
Type: Bug


Attachments (Terms of Use)
liveusb-creator --reset-mbr from f21 Beta-TC1 Workstation (1.40 MB, image/jpeg)
2014-10-06 22:50 UTC, satellitgo
no flags Details
syslinux-config (2.11 KB, text/plain)
2014-10-07 17:06 UTC, satellitgo
no flags Details
liveusb-creator -v (3.25 KB, text/plain)
2014-10-07 17:08 UTC, satellitgo
no flags Details

Description satellitgo 2014-10-06 15:41:11 UTC
Description of problem:
liveusb-creator creates non-booting Live USB

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.insert fat32 USB boot flag set
2.select f21-Beta-TC1 Live .iso
3.no persistence

Actual results:
USB boots to flashing cursor

Expected results:
Live USB to Boot.dd works for same f21-Beta TC1 live.iso

Additional info:
Older bug?
https://bugzilla.redhat.com/show_bug.cgi?id=644862

Comment 1 Fedora Blocker Bugs Application 2014-10-06 15:53:18 UTC
Proposed as a Freeze Exception for 21-beta by Fedora user satellit using the blocker tracking app because:

 liveusb-creator is one of main methods to install f21 on systems without optical drives

Comment 2 Luke Macken 2014-10-06 16:39:52 UTC
Does it work if you run `liveusb-creator --reset-mbr`?

Comment 3 satellitgo 2014-10-06 20:40:03 UTC
It does not seem to...will test again  I did (gparted) reset mbr format fat32 boot flag label LIVE last time. will try again with another USB

Comment 4 satellitgo 2014-10-06 22:50:24 UTC
Created attachment 944401 [details]
liveusb-creator --reset-mbr from f21 Beta-TC1 Workstation

error with 4 GB USB using liveusb-creator --reset-mbr from f21 _Beta-TC1 Workstation x86_64 install to bare metal

Comment 5 Luke Macken 2014-10-07 16:13:49 UTC
I cannot reproduce this issue. Could you please attach the output of `liveusb-creator -v` along with `syslinux/syslinux.cfg`?

Comment 6 satellitgo 2014-10-07 17:06:50 UTC
Created attachment 944682 [details]
syslinux-config

Comment 7 satellitgo 2014-10-07 17:08:28 UTC
Created attachment 944683 [details]
liveusb-creator -v

Comment 8 Luke Macken 2014-10-07 23:15:46 UTC
Can you try changing LABEL=LIVE in `EFI/BOOT/grub.cfg` to LABEL=Fedora-Live-Workstation-x86_64-2 and see if that fixes the issue?

Comment 9 Adam Williamson 2014-10-15 17:24:42 UTC
Discussed at 2014-10-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-15/f21-blocker-review.2014-10-15-16.04.log.txt . As we're not clear yet how widespread this is, what the cause is, or whether it will require any fixes in the image itself (not just LUC), we're delaying the FE decision for now. It'd be good if more folks can test this.

Comment 10 satellitgo 2014-10-15 23:15:27 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1145264 ?

"The ISO volume ID for the Fedora 21 workstation livecd is 'Fedora-Live-Workstation-x86_64-2', which doesn't actually say 21 in it, and libosinfo can't use it to detect the fedora version for boxes/virt-manager."

Comment 11 Adam Williamson 2014-10-18 01:54:33 UTC
dgilmore: what happened to the shortened names we were going to use for the volume IDs?

Comment 12 Kamil Páral 2014-10-20 18:11:41 UTC
Discussed in 2014-10-20 Blocker Review meeting [1]. We have decided to punt the decision and test this properly first.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-20/

Comment 13 Adam Williamson 2014-10-20 18:54:44 UTC
I couldn't reproduce this with the TC4 Workstation live.

I had to reformat my USB stick before luc would write to it - it won't do a destructive write so far as I can see, and my stick already had a live image on it (from dd), so there was no free space. So I wiped all partitions on the stick, creating a new one with W95 FAT32 type, formatted it with mkfs.vfat , then wrote the image to it with 'liveusb-creator --reset-mbr'.

It booted fine (BIOS mode).

Comment 14 satellitgo 2014-10-20 22:01:58 UTC
Work done from F21 Workstation live install to USB Hard Disk

liveusb creator --reset-mbr from fat partitioned 4 GB USB "LIVE"
(KDE -Live Beta TC4 x86_64 iso)

Bios Boot:
SYSLINUX 6.02 EDD...
Failed to load ldlinux.c32
Boot Failed:....

Comment 15 Jan Sedlák 2014-10-21 07:47:44 UTC
I have tried it on my machine and it worked. Formatted USB stick to FAT32, wrote Fedora 21 Workstation Live Beta TC4 on it using "liveusb-creator --reset-mbr" and it booted fine.

Comment 16 satellitgo 2014-10-21 15:21:17 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1036306#c9 :

"Booted KDE-Live-Beta-TC4 Live DVD. (Bios Boot)from external DVD drive
 mounted ssd drive in MSI WindBook (openSuse-edu 13.1)
 started liveusb-creator (present in KDE install).
 selected from ssd (openSuse-edu 13.1) Download directory:
 1 KDE-live Beta-TC4
 2 Workstation-live Beta-TC4
 3 Mate-live Beta-TC4 with Persistence file
 All 3 completed without errors and booted. and Persistence file worked in case #3
I have be unable to do this using workstation-live TC4 installed to USB hard-disk. with liveusb-creator installed with yum."

Why is this failing from a booted f21-live-Workstation TC4 install to bare metal?

Comment 17 satellitgo 2014-10-21 18:31:33 UTC
(In reply to satellitgo from comment #16)
> https://bugzilla.redhat.com/show_bug.cgi?id=1036306#c9 :
> 
> "Booted KDE-Live-Beta-TC4 Live DVD. (Bios Boot)from external DVD drive
>  mounted ssd drive in MSI WindBook (openSuse-edu 13.1)
>  started liveusb-creator (present in KDE install).
>  selected from ssd (openSuse-edu 13.1) Download directory:
>  1 KDE-live Beta-TC4
>  2 Workstation-live Beta-TC4
>  3 Mate-live Beta-TC4 with Persistence file
>  All 3 completed without errors and booted. and Persistence file worked in
> case #3
> I have be unable to do this using workstation-live TC4 installed to USB
> hard-disk. with liveusb-creator installed with yum."
> 
> Why is this failing from a booted f21-live-Workstation TC4 install to bare
> metal?

yum sees: syslinux.x86_64 0:6.03-1.fc21 on KDE live DVD

Comment 18 Adam Williamson 2014-10-22 18:12:43 UTC
Discussed at 2014-10-22 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-22/f21-blocker-review.2014-10-22-16.03.log.txt . Rejected as a freeze exception as the problem here seems to be with using luc from F21 itself, which we just don't really think is a very significant case, and can be fixed with updates.

We'd be more concerned about a bug in the f21 *images* which made them write incorrectly when written from f19 or f20 or Windows, but that doesn't seem to be the case here.

Comment 19 satellitgo 2014-10-26 20:59:38 UTC
https://fedoraproject.org/wiki/Test_Results:Fedora_21_Beta_RC1_Installation?rd=Test_Results:Current_Installation_Test

workstation-RC1 Live x86_64 from MATE-RC-1 install with "yum install liveusb-creator"

Looks fixed

Comment 20 Fedora Update System 2014-11-27 08:13:15 UTC
liveusb-creator-3.13.1-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.1-1.el7

Comment 21 Fedora Update System 2014-11-27 08:13:48 UTC
liveusb-creator-3.13.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.1-1.el6

Comment 22 Fedora Update System 2014-11-27 08:14:21 UTC
liveusb-creator-3.13.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.1-1.fc19

Comment 23 Fedora Update System 2014-11-27 08:14:54 UTC
liveusb-creator-3.13.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.1-1.fc21

Comment 24 Fedora Update System 2014-11-27 08:15:26 UTC
liveusb-creator-3.13.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.1-1.fc20

Comment 25 Fedora Update System 2014-11-27 19:27:22 UTC
Package liveusb-creator-3.13.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liveusb-creator-3.13.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15869/liveusb-creator-3.13.1-1.fc21
then log in and leave karma (feedback).

Comment 26 Fedora Update System 2014-12-06 10:16:33 UTC
liveusb-creator-3.13.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2014-12-12 23:17:25 UTC
liveusb-creator-3.13.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.2-1.el6

Comment 28 Fedora Update System 2014-12-12 23:17:59 UTC
liveusb-creator-3.13.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.2-1.fc20

Comment 29 Fedora Update System 2014-12-12 23:18:32 UTC
liveusb-creator-3.13.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.2-1.fc19

Comment 30 Fedora Update System 2014-12-12 23:19:03 UTC
liveusb-creator-3.13.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/liveusb-creator-3.13.2-1.fc21

Comment 31 Fedora Update System 2015-01-03 00:14:02 UTC
liveusb-creator-3.13.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2015-01-03 18:57:31 UTC
liveusb-creator-3.13.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2015-01-03 19:05:10 UTC
liveusb-creator-3.13.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2015-01-03 19:10:12 UTC
liveusb-creator-3.13.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.