Bug 1149952 - Python exception thrown when searching dnf history
Python exception thrown when searching dnf history
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-06 23:38 EDT by Daniel Miranda
Modified: 2014-12-13 04:53 EST (History)
6 users (show)

See Also:
Fixed In Version: dnf-0.6.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-13 04:53:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf.log (7.40 KB, text/plain)
2014-10-06 23:38 EDT, Daniel Miranda
no flags Details

  None (edit)
Description Daniel Miranda 2014-10-06 23:38:20 EDT
Created attachment 944437 [details]
dnf.log

Description of problem:

Trying to search for a package with `dnf history` causes a Python exception


Version-Release number of selected component (if applicable):

dnf-0:0.5.4-2.fc20
rpm-0:4.11.3-1


How reproducible:

Always


Steps to Reproduce:
1. Run `dnf history <package>`

Actual results:

Partial output followed by crash


Expected results:

No crash


Additional info:

Backtrace is attached
Comment 1 Parag Nemade 2014-10-07 00:03:16 EDT
I am not aware of any such usage of history command. I generally use it as

sudo dnf history list

sudo dnf history info <transaction ID>

but when I checked yum, I see yum can show package history and thus this can be missing feature in dnf. But I also see for a kernel like special package it failed to provide history when given as

sudo yum history info kernel-3.16-2

but following worked
sudo yum history info kernel
Comment 2 Daniel Miranda 2014-10-07 00:11:59 EDT
It's described in the manual:

dnf history info [<spec>...]
    Describe  the  given transactions. Each <spec> can be either a <transaction-spec>, which specifies a transaction directly, or a <package-name-spec>, which
    specifies a transaction by a package which it manipulated. When no transaction is specified describe what happened during the latest transaction.

And it does seem to work up to the point of the crash, which looks like right when the targetted package is about to be listed. Removing the version from the package name doesn't change anything for me though, passing just 'kernel', or even a different package like 'firefox' still causes an exception.
Comment 3 Parag Nemade 2014-10-07 00:48:16 EDT
I almost forgot this is already reported. I just installed new dnf-0.6.2 update on Fedora 21 where its update log showed bug 1136223 fixed.

I will not mark this as duplicate yet as I am not sure how kernel package should be used with history command. With the new update following only worked fine.

sudo dnf history info kernel
Comment 4 Daniel Miranda 2014-10-07 00:58:27 EDT
Is DNF 0.6 going to be on Fedora 20? If negative, this seems like something would warrant a backport, if I may say that.
Comment 5 Tim Lauridsen 2014-10-07 01:09:09 EDT
the dnf history info kernel case was fixed in 0.6.2

but dnf history info python* blows up

fixed here

https://github.com/rpm-software-management/dnf/pull/166
Comment 6 Honza Silhan 2014-10-08 16:32:38 EDT
Fixed in the upstream.
Comment 7 Fedora Update System 2014-12-09 09:06:26 EST
dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
Comment 8 Fedora Update System 2014-12-11 23:32:31 EST
Package dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.3-2.fc21 hawkey-0.5.2-1.fc21 dnf-plugins-core-0.1.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16760/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
then log in and leave karma (feedback).
Comment 9 Daniel Miranda 2014-12-12 00:19:15 EST
Command no longer crashes, and produces correct results for me with the updates.
Comment 10 Fedora Update System 2014-12-13 04:53:32 EST
dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.