Bug 115005 - Web Traceback forges From: dev-null@rhn.redhat.com
Web Traceback forges From: dev-null@rhn.redhat.com
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nick Hansen
Fanny Augustin
:
Depends On:
Blocks: 119091
  Show dependency treegraph
 
Reported: 2004-02-05 09:23 EST by Chris Kloiber
Modified: 2007-07-31 10:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-17 17:06:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2004-02-05 09:23:29 EST
Description of problem:

When I triggered Bug# 114979, I received a "Web Traceback" containing
information about the satellite state at the time of the incident.
That email originated from my local system, however the following
email headers incorrectly show that the sending system to be:

From dev-null@rhn.redhat.com Wed Feb  4 21:18:58 2004
Return-Path: <dev-null@rhn.redhat.com>
(snip)
X-Authentication-Warning: qa.ckloiber.com: apache set sender to Red
Hat Network <dev-null@rhn.redhat.com> using -f
(snip)
From: Red Hat Network <dev-null@rhn.redhat.com>
(snip)
Errors-To: Red Hat Network <dev-null@rhn.redhat.com>

(The full text of the Web Traceback is attatched to Bugzilla# 114979)
Comment 1 Robin Norwood 2004-03-03 09:18:32 EST
Defer to rhn330
Comment 2 Nick Hansen 2004-04-13 15:10:46 EDT
I'll make this a configurable variable for the rhn340sat release.
Comment 3 Nick Hansen 2004-05-21 12:10:24 EDT
The From: email address can now be configured via the
/etc/rhn/rhn.conf file by setting the 'web.default_mail_from'
parameter. If this parameter is not set, a default of 'Red Hat Network
<dev-null@rhn.redhat.com>' will be used.

Test plan:
After installing a satellite, edit /etc/rhn/rhn.conf with something like:
web.default_mail_from = booga@redhat.com 
or
web.default_mail_from = booga <booga@redhat.com>  

Save the file and then restart httpd. After that, do something that
generates an email (tickle code to cause a traceback, create a new
user or other such event) and verify that the email received has a
From: header equal to what you put in rhn.conf. If that is not the
case, this bug fails qa.
Comment 4 Fanny Augustin 2004-06-25 15:20:55 EDT
Looks good.
Comment 5 Pete Graner 2004-08-09 14:33:48 EDT
Put the following in /etc/rhn/rhn.conf

web.default_mail_from = Red Hat (Vienna, VA)
Satellite<admin@rhnsat.vienna.redhat.com>

Restarted httpd & taskomatic and now the From: looks like:           
                 

From: Red Hat Satellite <admin@redhat.com>

It looks like it stripped out everything between the () .

It also changed the domain name (dropped the hostname and the first
part of the domainname).
Comment 6 Todd Warner 2004-09-08 11:54:59 EDT
The () strippage is your email client I believe.
The domain munging is our "corporate rewrite rules in the corporate
email exchanger" (according to nhansen). I see the same behavior.
Comment 7 Nick Hansen 2005-06-17 17:06:01 EDT
As I'm sure this bug is working in production, I'm going to move it to closed.

Note You need to log in before you can comment on or make changes to this bug.