Bug 1150075 - [engine-backend] ActivateStorageDomainCommand fails on CDA for adding a new domain
Summary: [engine-backend] ActivateStorageDomainCommand fails on CDA for adding a new d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Maor
QA Contact: Elad
URL:
Whiteboard: storage
Depends On:
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-10-07 11:57 UTC by Elad
Modified: 2016-02-10 20:21 UTC (History)
14 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 19:13:22 UTC
oVirt Team: Storage


Attachments (Terms of Use)
engine.log (476.31 KB, application/x-gzip)
2014-10-07 11:57 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 33894 master MERGED core: Add context when calling to activate Storage Domain Never
oVirt gerrit 33895 ovirt-engine-3.5 MERGED core: Add context when calling to activate Storage Domain Never
oVirt gerrit 33897 refs/tags/ovirt-engine-3.5.0 MERGED core: Add context when calling to activate Storage Domain Never

Description Elad 2014-10-07 11:57:43 UTC
Created attachment 944549 [details]
engine.log

Description of problem:
As part of storage domain creation, ActivateStorageDomainCommand fails in CDA:

2014-10-07 14:45:24,789 WARN  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (ajp-/127.0.0.1:8702-3) [37393b37] CanDoAction of action ActivateStorageDomain failed. Reasons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__ACTIVATE,ACTION_TYPE_FAILED_OBJECT_LOCKED

This happens while adding a non-first in DC domain.

Version-Release number of selected component (if applicable):
rhev 3.5 vt5
rhevm-3.5.0-0.14.beta.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. On a DC with a storage domain, create an additional domain


Actual results:
Storage domain activation fails on CanDoAction:

2014-10-07 14:45:24,789 INFO  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (ajp-/127.0.0.1:8702-3) [37393b37] Failed to Acquire Lock to object EngineLock [exclusiveLocks= key: f3f5c5d0-b775-4ba6-a0d6-2fc4ae0d6fb7 value: STORAGE
, sharedLocks= ]
2014-10-07 14:45:24,789 WARN  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (ajp-/127.0.0.1:8702-3) [37393b37] CanDoAction of action ActivateStorageDomain failed. Reasons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__ACTIVATE,ACTION_TYPE_FAILED_OBJECT_LOCKED


Expected results:
Storage domain activation should succeed

Additional info:
 engine.log

Comment 1 Tal Nisan 2014-10-07 12:14:03 UTC
Maor, this looks like a regression that was caused after one of the locking changes you introduced, can you please check?

Comment 3 Maor 2014-10-07 12:33:13 UTC
Is it reproduce also without json?

Comment 4 Elad 2014-10-07 12:54:02 UTC
(In reply to Maor from comment #3)
> Is it reproduce also without json?

Yes

Comment 5 Elad 2014-10-22 11:45:39 UTC
Storage domain activation succeeded for adding a new storage domain (not the first)

2014-10-22 14:42:41,897 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.ActivateStorageDomainVDSCommand] (ajp-/127.0.0.1:8702-1) [3c37311] START, ActivateStorageDomainVDSCommand( storagePoolId = 00000002-0002-0002-0002-000000000328, ignoreFailoverLimit = false, storageDomainId = cba68e49-efdb-4f9c-9ad0-17319d213237), log id: 6fb1d91e
2014-10-22 14:42:42,444 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.ActivateStorageDomainVDSCommand] (ajp-/127.0.0.1:8702-1) [3c37311] FINISH, ActivateStorageDomainVDSCommand, return: true, log id: 6fb1d91e
2014-10-22 14:42:42,444 INFO  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (ajp-/127.0.0.1:8702-1) [3c37311] ActivateStorage Domain. After Connect all hosts to pool. Time:10/22/14 2:42 PM
2014-10-22 14:42:42,459 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStoragePoolVDSCommand] (org.ovirt.thread.pool-7-thread-47) START, ConnectStoragePoolVDSCommand(HostName = green-vdsb, HostId = 4fa18390-60b8-4061-9c25-1ade07c4e2e2, vdsId = 4fa18390-60b8-4061-9c25-1ade07c4e2e2, storagePoolId = 00000002-0002-0002-0002-000000000328, masterVersion = 1), log id: 764d5432
2014-10-22 14:42:43,347 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStoragePoolVDSCommand] (org.ovirt.thread.pool-7-thread-47) FINISH, ConnectStoragePoolVDSCommand, log id: 764d5432
2014-10-22 14:42:43,347 INFO  [org.ovirt.engine.core.bll.storage.RefreshPoolSingleAsyncOperation] (org.ovirt.thread.pool-7-thread-47) Refreshed vds green-vdsb in pool Default
2014-10-22 14:42:43,349 INFO  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (ajp-/127.0.0.1:8702-1) [3c37311] ActivateStorage Domain. After change storage pool status in vds. Time:10/22/14 2:42



Verified using rhev3.5 vt6

Comment 6 Allon Mureinik 2015-02-16 19:13:22 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 7 Allon Mureinik 2015-02-16 19:13:22 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.