Bug 115028 - [PATCH] rc.sysinit fsck bug fixes and enhancements
[PATCH] rc.sysinit fsck bug fixes and enhancements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: EasyFix, Patch, StringChange
: 53003 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 12:12 EST by Leonard den Ottolander
Modified: 2014-03-16 22:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.69-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 15:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Changes integer =s to -eqs and clarifies forced fs check (3.41 KB, patch)
2004-02-05 12:14 EST, Leonard den Ottolander
no flags Details | Diff

  None (edit)
Description Leonard den Ottolander 2004-02-05 12:12:32 EST
initscripts-7.42.2-1

Integer comparisions of $rc should use "-eq" instead of "=" (lines
270, 273, 300, 532, 535 and 562).

Integer comparisions of $usb should use "-eq" instead of "="  (lines
199 and 204).

$_RUN_QUOTACHECK and $_ROOT_HAS_QUOTA comparision cleanup (lines 310
and 311).

The "press Y to force file system check" seems to confuse some people
as it only applies to (apparently) clean file systems. Added an echo
to clear this up, and changed the question echos to explicitely state
that the forced check only applies to clean file systems. You might
want to drop these, but leave in the echo "Unclean file systems will
be checked".

Bug #53003 can be closed as a duplicate of this bug (not the other way
'round).
Comment 1 Leonard den Ottolander 2004-02-05 12:14:38 EST
Created attachment 97493 [details]
Changes integer =s to -eqs and clarifies forced fs check
Comment 2 Bill Nottingham 2004-02-11 20:51:28 EST
*** Bug 53003 has been marked as a duplicate of this bug. ***
Comment 3 Leonard den Ottolander 2004-08-12 13:31:41 EDT
Still the same situation for FC3t1, initscripts-7.60-1. This is an
EASYFIX.
Comment 4 Bill Nottingham 2004-08-25 15:43:49 EDT
Added, aside from the fsck stuff. That will all change differently anyway.

Note You need to log in before you can comment on or make changes to this bug.