Bug 1150349 - [abrt] freerdp: fatal_handler(): xfreerdp killed by SIGSEGV
Summary: [abrt] freerdp: fatal_handler(): xfreerdp killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freerdp
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b061d77382fd419af0dc81b95a9...
: 1168183 (view as bug list)
Depends On:
Blocks: 1175727
TreeView+ depends on / blocked
 
Reported: 2014-10-08 02:26 UTC by lonelywoolf
Modified: 2015-02-15 13:56 UTC (History)
16 users (show)

Fixed In Version: freerdp-1.2.0-0.6.beta.1.fc21.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-15 13:56:15 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (11.84 KB, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: cgroup (190 bytes, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: core_backtrace (3.42 KB, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: dso_list (6.57 KB, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: environ (1.66 KB, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: limits (1.29 KB, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: maps (29.50 KB, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: open_fds (636 bytes, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: proc_pid_status (936 bytes, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details
File: var_log_messages (202 bytes, text/plain)
2014-10-08 02:26 UTC, lonelywoolf
no flags Details

Description lonelywoolf 2014-10-08 02:26:18 UTC
Description of problem:
Tried to connect with KRDC to windows machine via RDP

Version-Release number of selected component:
freerdp-1.2.0-0.2.beta.1.fc21

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        xfreerdp -g 1366x768 -k 0x00000409 -d powernetworks -u Admin -p Flvby$44 -D -X 113246464 -a 24 --plugin rdpsnd --plugin rdpdr --data disk:media:/media -- -x l --rfx --ignore-certificate --plugin cliprdr -t 3389 192.168.0.10
crash_function: fatal_handler
executable:     /usr/bin/xfreerdp
kernel:         3.16.3-302.fc21.x86_64+debug
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #1 fatal_handler at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/libfreerdp/utils/signal.c:66
 #3 __memcpy_avx_unaligned at ../sysdeps/x86_64/multiarch/memcpy-avx-unaligned.S:245
 #4 memcpy at /usr/include/bits/string3.h:51
 #5 freerdp_client_old_command_line_pre_filter at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/client/common/compatibility.c:268
 #6 CommandLineParseArgumentsA at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/winpr/libwinpr/utils/cmdline.c:100
 #7 freerdp_detect_old_command_line_syntax at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/client/common/compatibility.c:335
 #8 freerdp_client_detect_command_line at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/client/common/cmdline.c:1038
 #9 freerdp_client_settings_parse_command_line_arguments at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/client/common/cmdline.c:1136
 #10 freerdp_client_settings_parse_command_line at /usr/src/debug/FreeRDP-1.2.0-beta1-android7/client/common/client.c:114

Comment 1 lonelywoolf 2014-10-08 02:26:22 UTC
Created attachment 944827 [details]
File: backtrace

Comment 2 lonelywoolf 2014-10-08 02:26:24 UTC
Created attachment 944828 [details]
File: cgroup

Comment 3 lonelywoolf 2014-10-08 02:26:26 UTC
Created attachment 944829 [details]
File: core_backtrace

Comment 4 lonelywoolf 2014-10-08 02:26:27 UTC
Created attachment 944830 [details]
File: dso_list

Comment 5 lonelywoolf 2014-10-08 02:26:29 UTC
Created attachment 944831 [details]
File: environ

Comment 6 lonelywoolf 2014-10-08 02:26:31 UTC
Created attachment 944832 [details]
File: limits

Comment 7 lonelywoolf 2014-10-08 02:26:33 UTC
Created attachment 944833 [details]
File: maps

Comment 8 lonelywoolf 2014-10-08 02:26:47 UTC
Created attachment 944834 [details]
File: open_fds

Comment 9 lonelywoolf 2014-10-08 02:26:56 UTC
Created attachment 944835 [details]
File: proc_pid_status

Comment 10 lonelywoolf 2014-10-08 02:26:58 UTC
Created attachment 944836 [details]
File: var_log_messages

Comment 11 pscdvl 2014-10-22 13:14:37 UTC
Another user experienced a similar problem:

open rdp connect in krdc. rdp session not start, see only blue screen. On remmina rdp session is open.

reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        xfreerdp -g 800x600 -k 0x00000409 -u administrator -p df4cKuWpZ -D -X 71303367 -a 24 --plugin rdpsnd --plugin rdpdr --data disk:media:/media -- -x l --rfx --ignore-certificate --plugin cliprdr -t 3389 srvbuh1
crash_function: fatal_handler
executable:     /usr/bin/xfreerdp
kernel:         3.16.1-301.fc21.x86_64
package:        freerdp-1.2.0-0.2.beta.1.fc21
reason:         xfreerdp killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1001

Comment 12 Joel Burleson-Davis 2014-12-08 14:44:27 UTC
I'm seeing this as well after an upgrade to F21. F20 was just fine though, and as pscdvl said, Remmina + FreeRDP is working as expected.

Comment 13 Giuseppe Ravasio 2014-12-17 22:00:59 UTC
Same problem here...

Comment 14 Ian Morgan 2014-12-18 15:45:39 UTC
Same major disappointment here.. pretty big blunder to have slipped past QA. :-(

I worked around the problemn as follows:

Download these F20 packages from your local mirror:
freerdp-1.0.2-6.fc20
freerdp-libs-1.0.2-6.fc20
freerdp-plugins-1.0.2-6.fc20

Remove packages with version conflicts:
rpm -e vinagre vlc vlc-core

Then force-install the F20 packages:

rpm -Uvh --force freerdp-1.0.2-6.fc20.x86_64.rpm freerdp-libs-1.0.2-6.fc20.x86_64.rpm freerdp-plugins-1.0.2-6.fc20.x86_64.rpm

Now KRDC is happy again.

Until The KDE team get KRDC updated to work with freerdp 1.2.x, can Fedora please provide a compat-freerdp10 package?

Comment 15 Rex Dieter 2014-12-19 15:02:18 UTC
Upstream report,
https://github.com/FreeRDP/FreeRDP/issues/2172

Comment 16 Rex Dieter 2014-12-19 16:25:10 UTC
fyi, for krdc not working, that is being tracked in bug #1175727

Comment 17 Orion Poplawski 2015-01-14 17:15:49 UTC
Caused by upstream commit c5fc2de7107c5f80ca68c72b01355bb7bb3a1527

Comment 18 Rex Dieter 2015-01-14 17:31:52 UTC
by the looks of it:
https://github.com/FreeRDP/FreeRDP/issues/2172

Comment 19 Orion Poplawski 2015-01-14 18:07:23 UTC
Bigger issue is that the command line arguments have completely changed with 1.2.0 and do not appear to be backward compatible.

Comment 20 Rex Dieter 2015-01-14 18:16:16 UTC
there's that too :(  (the command-line changes landed in 1.1 initially, didn't it?)

Comment 21 Orion Poplawski 2015-01-14 23:05:53 UTC
*** Bug 1168183 has been marked as a duplicate of this bug. ***

Comment 22 Fedora Update System 2015-01-14 23:29:18 UTC
freerdp-1.2.0-0.5.beta.1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/freerdp-1.2.0-0.5.beta.1.fc21

Comment 23 Fedora Update System 2015-01-17 05:46:36 UTC
Package freerdp-1.2.0-0.6.beta.1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freerdp-1.2.0-0.6.beta.1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0812/freerdp-1.2.0-0.6.beta.1.fc21
then log in and leave karma (feedback).

Comment 24 Fedora Update System 2015-01-27 02:56:22 UTC
Package freerdp-1.2.0-0.6.beta.1.fc21.1:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freerdp-1.2.0-0.6.beta.1.fc21.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0812/freerdp-1.2.0-0.6.beta.1.fc21.1
then log in and leave karma (feedback).

Comment 25 Fedora Update System 2015-02-15 13:56:15 UTC
freerdp-1.2.0-0.6.beta.1.fc21.1 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.