Bug 1150419 - Logical volume does not exist error at VM startup when volume already exists at volume creation
Summary: Logical volume does not exist error at VM startup when volume already exists ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: Elad
URL:
Whiteboard: storage
Depends On: 1136199 1155637
Blocks: 1094657 1099882
TreeView+ depends on / blocked
 
Reported: 2014-10-08 09:04 UTC by Artyom
Modified: 2016-02-10 18:01 UTC (History)
12 users (show)

Fixed In Version: ovirt-engine-3.5.0_vt12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:39:35 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
logs (538.05 KB, application/zip)
2014-10-08 09:04 UTC, Artyom
no flags Details

Description Artyom 2014-10-08 09:04:24 UTC
Created attachment 944887 [details]
logs

Description of problem:
Hosted-engine --deploy failed with iscsi storage with error: Cannot set temporary password for console connection. The VM may not have been created: please check VDSM logs


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.1-1.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run hosted-engine --deploy with iscsi storage
2.
3.

Actual results:
deployment fail with error: Failed to execute stage 'Closing up': Cannot set temporary password for console connection. The VM may not have been created: please check VDSM logs

Expected results:
Deployment success without any errors.

Additional info:

Comment 1 Sandro Bonazzola 2014-10-08 13:59:47 UTC
VM did not start due to:

Thread-75::ERROR::2014-10-08 11:50:13,185::task::866::Storage.TaskManager.Task::(_setError) Task=`1d33c84c-e495-41c6-b28b-6ff45e83005d`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 3099, in getVolumeSize
    apparentsize = str(dom.getVSize(imgUUID, volUUID))
  File "/usr/share/vdsm/storage/blockSD.py", line 622, in getVSize
    size = lvm.getLV(self.sdUUID, volUUID).size
  File "/usr/share/vdsm/storage/lvm.py", line 893, in getLV
    raise se.LogicalVolumeDoesNotExistError("%s/%s" % (vgName, lvName))
LogicalVolumeDoesNotExistError: Logical volume does not exist: ('80b976a8-d02b-497e-84ae-42a2d72826cc/514ac661-3306-4654-b3e9-d874187e1a61',)

this is the downstream equivalent of bug #1136199 .
About the misreported error about the VM ticket, a bug has been already opened as bug #1144334.

Comment 2 Allon Mureinik 2014-10-21 15:04:55 UTC
(In reply to Sandro Bonazzola from comment #1)
> this is the downstream equivalent of bug #1136199 .
> About the misreported error about the VM ticket, a bug has been already
> opened as bug #1144334.
Both these bugs are on integration.
Why was this one moved to storage?

Comment 3 Sandro Bonazzola 2014-10-23 13:20:44 UTC
(In reply to Allon Mureinik from comment #2)
> (In reply to Sandro Bonazzola from comment #1)
> > this is the downstream equivalent of bug #1136199 .
> > About the misreported error about the VM ticket, a bug has been already
> > opened as bug #1144334.
> Both these bugs are on integration.
> Why was this one moved to storage?

sorry, forgot to move to storage bug #1136199.

Comment 4 Allon Mureinik 2014-11-19 14:18:04 UTC
(In reply to Sandro Bonazzola from comment #3)
> (In reply to Allon Mureinik from comment #2)
> > (In reply to Sandro Bonazzola from comment #1)
> > > this is the downstream equivalent of bug #1136199 .
> > > About the misreported error about the VM ticket, a bug has been already
> > > opened as bug #1144334.
> > Both these bugs are on integration.
> > Why was this one moved to storage?
> 
> sorry, forgot to move to storage bug #1136199.

Moving to ON_QA - should be tested with the latest build.

Comment 5 Elad 2014-12-01 08:39:19 UTC
Cannot be tested, blocked due to https://bugzilla.redhat.com/show_bug.cgi?id=1155637

Comment 6 Allon Mureinik 2014-12-02 07:18:42 UTC
(In reply to Elad from comment #5)
> Cannot be tested, blocked due to
> https://bugzilla.redhat.com/show_bug.cgi?id=1155637
VT12 has moved this one to ON_QA too.

Comment 7 Elad 2014-12-14 15:02:01 UTC
Verifying based on https://bugzilla.redhat.com/show_bug.cgi?id=1136199#c5


Note You need to log in before you can comment on or make changes to this bug.