Bug 1155637 - [hosted-engine][iscsi] [dirty storage] [ ERROR ] Failed to execute stage 'Misc configuration': Wrong Master domain or its version:
Summary: [hosted-engine][iscsi] [dirty storage] [ ERROR ] Failed to execute stage 'Mis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Elad
URL:
Whiteboard:
: 1158822 (view as bug list)
Depends On: 1215623 1220824
Blocks: 1150419 1199905
TreeView+ depends on / blocked
 
Reported: 2014-10-22 14:02 UTC by Jiri Belka
Modified: 2016-03-09 19:06 UTC (History)
11 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.1-5.el7ev
Doc Type: Bug Fix
Doc Text:
Additional VDSM flags have been added to improve handling of pre-existing storage domains in hosted engine deployments.
Clone Of:
: 1199905 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:06:05 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)
/var/log (146.14 KB, application/x-xz)
2014-10-22 14:02 UTC, Jiri Belka
no flags Details
metadata lv data (9.54 MB, application/x-xz)
2014-10-23 09:36 UTC, Jiri Belka
no flags Details
logs (223.42 KB, application/x-gzip)
2014-12-25 10:15 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 35351 master MERGED packaging: setup: better handling of preexisting storage domain Never
oVirt gerrit 35388 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: better handling of preexisting storage domain Never
oVirt gerrit 36811 master MERGED packaging: setup: better handling of dirty storage Never

Description Jiri Belka 2014-10-22 14:02:28 UTC
Created attachment 949403 [details]
/var/log

Description of problem:

hosted-engine --deploy # with iscsi storage for the VM.
...
          Please specify the storage you would like to use (iscsi, nfs3, nfs4)[nfs3]: iscsi
          Please specify the iSCSI portal IP address: 10.34.63.202
          Please specify the iSCSI portal port [3260]: 
          Please specify the iSCSI portal user: 
          Please specify the target name (iqn.2011-01.brq.str-01:pstehlik, iqn.2012-06.brq.str-01:brq-setup, iqn.2012-10.brq.str-01:cmestreg, iqn.2012-10.brq.str-01:kjachim, iqn
.2012-10.brq.str-01:lbednar, iqn.2012-10.brq.str-01:mbetak, iqn.2013-12.brq.str-01:ha-tests, iqn.2013-12.brq.str-01:jbelka, iqn.2013-12.brq.str-01:mpavlik) [iqn.2011-01.brq.str-
01:pstehlik]: iqn.2013-12.brq.str-01:jbelka 
          The following luns have been found on the requested target:
                 1 - sdb - 18432MB
                 2 - sdc - 18432MB
                 3 - sdd - 30720MB
          Please specify the lun id (1, 2, 3) [1]: 3
          The specified storage location already contains a data domain. Is this an additional host setup (Yes, No)[Yes]? No
[ INFO  ] Installing on first host
          Please provide storage domain name. [hosted_storage]:
...
        --== CONFIGURATION PREVIEW ==--
         
          Engine FQDN                        : jb-hostedengine.rhev.lab.eng.brq.redhat.com
          Bridge name                        : rhevm
          SSH daemon port                    : 22
          Firewall manager                   : iptables
          Gateway address                    : 10.34.63.254
          Host name for web application      : hosted_engine_1
          iSCSI Target Name                  : iqn.2013-12.brq.str-01:jbelka
          iSCSI Portal port                  : 3260
          Host ID                            : 1
          iSCSI LUN ID                       : 3
          Image size GB                      : 25
          iSCSI Portal IP Address            : 10.34.63.202
          iSCSI Portal user                  : 
          Console type                       : vnc
          Memory size MB                     : 4096
          MAC address                        : 00:16:3e:34:d7:a1
          Boot type                          : pxe
          Number of CPUs                     : 2
          CPU Type                           : model_SandyBridge
...
[ INFO  ] Connecting Storage Pool
[ ERROR ] Failed to execute stage 'Misc configuration': Wrong Master domain or its version: 'SD=e133f938-1bce-4777-b3da-e9f951a377f8, pool=00000002-0002-0002-0002-0000000001f1'
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Answer file '/etc/ovirt-hosted-engine/answers.conf' has been updated
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

Version-Release number of selected component (if applicable):
vdsm-4.16.7-1.el6ev.x86_64
vdsm-python-4.16.7-1.el6ev.noarch
ovirt-hosted-engine-ha-1.2.4-1.el6ev.noarch
vdsm-python-zombiereaper-4.16.7-1.el6ev.noarch
ovirt-host-deploy-1.3.0-1.el6ev.noarch
vdsm-xmlrpc-4.16.7-1.el6ev.noarch
vdsm-yajsonrpc-4.16.7-1.el6ev.noarch
ovirt-hosted-engine-setup-1.2.1-1.el6ev.noarch
vdsm-cli-4.16.7-1.el6ev.noarch
vdsm-jsonrpc-4.16.7-1.el6ev.noarch

How reproducible:
100 %

Steps to Reproduce:
1. hosted-engine --deploy # use iscsi
2.
3.

Actual results:
failes on some domain issue

Expected results:
should work

Additional info:

Comment 1 Jiri Belka 2014-10-23 09:32:39 UTC
(existing) 'metadata' lv is doesn't have filesystem, strings against raw lv and output is in attachment.

[root@dell-r210ii-04 ~]# multipath -ll /dev/dm-4
1jbelka03 dm-4 RH-str01,VIRTUAL-DISK
size=30G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  `- 7:0:0:3 sdd 8:48 active ready running

[root@dell-r210ii-04 ~]# pvs /dev/mapper/1jbelka03
  PV                    VG                                   Fmt  Attr PSize  PFree 
  /dev/mapper/1jbelka03 e133f938-1bce-4777-b3da-e9f951a377f8 lvm2 a--  29.62g 25.50g

[root@dell-r210ii-04 ~]# lvs e133f938-1bce-4777-b3da-e9f951a377f8
  LV                                   VG                                   Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  33a2ea30-7e68-4c24-9920-c478772cbc2b e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a----- 128.00m                                                    
  63374fb6-94be-4d40-be5a-5c91b451be72 e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a----- 128.00m                                                    
  ids                                  e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a----- 128.00m                                                    
  inbox                                e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a----- 128.00m                                                    
  leases                               e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a-----   2.00g                                                    
  master                               e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a-----   1.00g                                                    
  metadata                             e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a----- 512.00m                                                    
  outbox                               e133f938-1bce-4777-b3da-e9f951a377f8 -wi-a----- 128.00m

[root@dell-r210ii-04 ~]# blkid | grep e133
/dev/mapper/e133f938--1bce--4777--b3da--e9f951a377f8-master: UUID="ae3d2f7c-e199-4dc9-9fe3-8459f445d35c" SEC_TYPE="ext2" TYPE="ext3"

Comment 2 Jiri Belka 2014-10-23 09:36:22 UTC
Created attachment 949768 [details]
metadata lv data

Comment 3 Jiri Belka 2014-10-23 09:49:02 UTC
i'll try with clean iscsi lun but later, now verificationthon :)

Comment 4 Sandro Bonazzola 2014-10-23 11:15:00 UTC
Which kind of storage domain was in lun 3 before running hosted-engine --deploy?

 Please specify the lun id (1, 2, 3) [1]: 3
 The specified storage location already contains a data domain. Is this an additional host setup (Yes, No)[Yes]? No

Comment 5 Jiri Belka 2014-10-23 12:31:24 UTC
data domain

Comment 6 Doron Fediuck 2014-10-28 13:19:17 UTC
This has nothing to do with bug 1149634, removing dependency.
Next time please verify with the relevant team before creating such dependency.

This issue is a result of a dirty environment. It should not effect
any proper upgrade or clean install.

Comment 7 Sandro Bonazzola 2014-10-30 10:25:11 UTC
*** Bug 1158822 has been marked as a duplicate of this bug. ***

Comment 8 Sandro Bonazzola 2014-11-20 07:44:33 UTC
Re-targeting to 3.5.0 after discussion about current implementation with storage team.

Comment 10 Elad 2014-12-25 10:12:58 UTC
Used a LUN that have a storage domain which was master domain in a different setup.
Deployment still fails with the same error:


RuntimeError: Wrong Master domain or its version: 'SD=ae05**FILTERED**daa-e6**FILTERED**f-42e8-8fd9-b67f338c5365, pool=00000002-0002-0002-0002-00000000037b'
20**FILTERED**4-**FILTERED**2-25 **FILTERED**2:02:2**FILTERED** ERROR otopi.context context._executeMethod:**FILTERED**6**FILTERED** Failed to execute stage 'Misc configuration': Wrong Master domain or its version
: 'SD=ae05**FILTERED**daa-e6**FILTERED**f-42e8-8fd9-b67f338c5365, pool=00000002-0002-0002-0002-00000000037b'

Checked using rhev 3.5 vt13.5 
ovirt-hosted-engine-setup-1.2.1-8.el6ev.noarch
vdsm-4.16.8.1-4.el6ev.x86_64
sanlock-2.8-1.el6.x86_64
selinux-policy-3.7.19-260.el6_6.1.noarch

Re-openning

Comment 11 Elad 2014-12-25 10:15:31 UTC
Created attachment 972966 [details]
logs

Comment 13 Sandro Bonazzola 2015-02-18 14:19:37 UTC
Simone, this BZ is in post but I see all referenced patches have been merged.
Can you sync this BZ status?

Comment 15 Elad 2015-05-19 11:38:03 UTC
Cannot be tested due to https://bugzilla.redhat.com/show_bug.cgi?id=1215623

Comment 16 Elad 2015-06-17 09:51:54 UTC
Deployment over a dirty LUN that contained a data domain in it works as expected.

Verified using 3.6.0-1

vdsm-4.17.0-912.git25a063d.el7.noarch
ovirt-hosted-engine-setup-1.3.0-0.0.master.20150518075146.gitdd9741f.el7.noarch

Comment 18 errata-xmlrpc 2016-03-09 19:06:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.