Bug 115055 - esd fills $HOME with coredumps
esd fills $HOME with coredumps
Status: CLOSED DUPLICATE of bug 114326
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 17:42 EST by Karsten Hopp
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2004-02-05 17:42:11 EST
Description of problem: 
esd segfaults immediately on startup 
 
Version-Release number of selected component (if applicable): 
esound-0.2.32-2 
 
How reproducible: 
always 
 
Steps to Reproduce: 
1. allow coredumps in /etc/profile 
2. start esound 
3. watch it segfault 
   
Actual results: 
>gdb esd 
GNU gdb Red Hat Linux (6.0post-0.20031117.7rh) 
Copyright 2003 Free Software Foundation, Inc. 
GDB is free software, covered by the GNU General Public License, and 
you are 
welcome to change it and/or distribute copies of it under certain 
conditions. 
Type "show copying" to see the conditions. 
There is absolutely no warranty for GDB.  Type "show warranty" for 
details. 
This GDB was configured as "i386-redhat-linux-gnu"...Using host 
libthread_db library "/lib/tls/libthread_db.so.1". 
 
(gdb) r 
Starting program: /usr/bin/esd 
[Thread debugging using libthread_db enabled] 
[New Thread -1207146080 (LWP 20558)] 
 
Program received signal SIGSEGV, Segmentation fault. 
[Switching to Thread -1207146080 (LWP 20558)] 
0x05c6071a in snd_pcm_hw_param_set_near () from 
/usr/lib/libasound.so.2 
(gdb) bt 
#0  0x05c6071a in snd_pcm_hw_param_set_near () from 
/usr/lib/libasound.so.2 
#1  0x05c58e8d in snd_pcm_hw_params_set_rate_near () 
   from /usr/lib/libasound.so.2 
#2  0xbff50e70 in ?? () 
#3  0x0000000b in ?? () 
#4  0x0000ac44 in ?? () 
(gdb)
Comment 1 Tom Diehl 2004-02-10 14:39:17 EST
huh?? Why was 115309 added as a dep? what does nis have to do with
esd? sorry if I am missing something.
Comment 2 Aleksey Nogin 2004-02-20 06:18:52 EST

*** This bug has been marked as a duplicate of 114326 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.