Bug 114326 - [patch] Segfaults when built with alsa
[patch] Segfaults when built with alsa
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: esound (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 115055 115607 116544 116585 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-01-26 12:58 EST by Enrico Scholz
Modified: 2007-04-18 13:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 06:05:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes segfault with alsa-1 (1.10 KB, patch)
2004-01-26 12:59 EST, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2004-01-26 12:58:28 EST
Description of problem:

when compiling in alsa support (default, when alsa-lib is installed),
esd coredumps at startup. This might be caused by a changed alsa API,
or unsufficient testing ;)

Attached patch fixes it, although I am not really sure about the
BUFFERSIZE related hunks.


Version-Release number of selected component (if applicable):

esound-0.2.32-2
Comment 1 Enrico Scholz 2004-01-26 12:59:35 EST
Created attachment 97258 [details]
fixes segfault with alsa-1
Comment 2 Aleksey Nogin 2004-02-20 06:18:11 EST
Here is a stack trace:

(gdb) bt
#0  snd_pcm_hw_param_set_near (pcm=0x8e7d140, params=0xbfe41270,
var=SNDRV_PCM_HW_PARAM_RATE, val=0xac44, dir=0x0)
    at pcm_params.c:786
#1  0x00ea812d in __snd_pcm_hw_params_set_rate_near (pcm=0xac44,
params=0xac44, val=0xac44, dir=0xac44) at pcm.c:3599
#2  0x00cb5250 in initAlsa () from /usr/lib/libesd.so.0
#3  0x00cb5767 in esd_audio_open () from /usr/lib/libesd.so.0
#4  0x0804a51b in ?? ()
Comment 3 Aleksey Nogin 2004-02-20 06:18:55 EST
*** Bug 115055 has been marked as a duplicate of this bug. ***
Comment 4 Aleksey Nogin 2004-02-20 06:19:44 EST
*** Bug 115607 has been marked as a duplicate of this bug. ***
Comment 5 Aleksey Nogin 2004-02-20 06:20:46 EST
Copying "blocks bug 114961" from the dup bug 115607.
Comment 6 Bill Nottingham 2004-02-23 18:52:05 EST
*** Bug 116544 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2004-02-23 18:52:09 EST
*** Bug 116585 has been marked as a duplicate of this bug. ***
Comment 8 Aleksey Nogin 2004-02-23 19:05:51 EST
I believe this was fixed upstream -
http://cvs.gnome.org/bonsai/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvs/gnome&subdir=esound&command=DIFF_FRAMESET&file=audio_alsa09.c&rev2=1.10&rev1=1.9

The corresponding changelog entry is

2004-01-15  Frederic Crozat  <fcrozat@mandrakesoft.com>

	* acconfig.h:
	* audio_alsa09.c:
	* configure.in: Use new ALSA PCM API if available
	(fixes from Lukasz Mach <lukasz@mach.com.pl> and 
	Eddy Mulyono <eddymulyono@mail.com>)
Comment 9 Aleksey Nogin 2004-02-25 01:32:30 EST
triage->easyfix, triage->upstream (a patch is attached - see comment
#2 and upstream have already fixed it as well - see comment #8).
Comment 10 Alexander Larsson 2004-03-03 10:42:26 EST
I built esound-0.2.33-1, which should have that change. Could you test it?
Comment 11 Aleksey Nogin 2004-03-03 12:13:54 EST
Would be happy to. Where do I get it?
Comment 12 Aleksey Nogin 2004-03-04 17:15:20 EST
esound-0.2.33-1 - no segfault. 

P.S. See bug 117522.
Comment 13 Warren Togami 2004-03-18 23:58:04 EST
So this is fixed?  Why is it not closed?

Note You need to log in before you can comment on or make changes to this bug.