Bug 115070 - kdemultimedia should include juk
kdemultimedia should include juk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 22:41 EST by Keunwoo Lee
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 10:38:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
taglib spec file (1.25 KB, text/plain)
2004-02-13 03:42 EST, Keunwoo Lee
no flags Details

  None (edit)
Description Keunwoo Lee 2004-02-05 22:41:55 EST
This is regarding the Fedora KDE 3.2 packages on the KDE mirrors.  
They are not on the official Fedora repositories, but the packager 
line says "Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>" and 
so I am reporting here. 
 
For some reason, the kdemultimedia packages do not include the juk 
media player.  Since I consider juk to be superior to the other two 
KDE media players (which are included), this is disappointing. 
 
Oddly, however, the kdemultimedia package does include some help 
files related to juk: 
 
$ rpm -q --filesbypkg kdemultimedia |grep juk 
kdemultimedia             /usr/share/doc/HTML/en/juk 
kdemultimedia             /usr/share/doc/HTML/en/juk/common 
kdemultimedia             /usr/share/doc/HTML/en/juk/index.cache.bz2 
kdemultimedia             /usr/share/doc/HTML/en/juk/index.docbook 
kdemultimedia             /usr/share/doc/HTML/en/juk/toolbar.png 
 
If juk is going to be packaged separately, please disregard this 
bug, although there's no juk Fedora RPM currently on the KDE mirrors 
based on KDE 3.2.
Comment 1 Keunwoo Lee 2004-02-13 03:41:10 EST
OK, I downloaded the SRPM for kdemultimedia to figure out why juk 
isn't building.  It appears that the reason is that taglib isn't 
present. 
 
Fedora Core 1 doesn't have a taglib RPM, and taglib is not currently 
in the package list for Fedora Core 2.  So, I'm attaching a specfile 
that can build the taglib 1.0 tarball.  This may need some tweaking, 
but anyway it's a start.  taglib has no dependencies so it should be 
low-overhead to maintain.  I've tested it on my Core 1 system; with 
the presence of this RPM, kdemultimedia at least attempts to build 
juk. 
 
The taglib tarball is at: 
 
http://ktown.kde.org/~wheeler/taglib/taglib-1.0.tar.gz 
 
BTW the taglib homepage: 
 
http://ktown.kde.org/~wheeler/taglib/ 
Comment 2 Keunwoo Lee 2004-02-13 03:42:33 EST
Created attachment 97638 [details]
taglib spec file
Comment 3 Ngo Than 2004-02-13 10:38:45 EST
i have already rebuilt all kde 3.2 against qt 3.3.0 yesterday. This
new on will include juk of course. I will upload one soon on ftp.kde.org


Comment 4 Ismael Juma 2004-03-06 17:51:44 EST
I have kdemultimedia-3.2.0-1.3 installed from rawhide and juk is still
not there. 

Running "rpm -q --filesbypkg kdemultimedia |grep juk" produces exactly
the same output as the one in the bug opening comment.

If the bug is fixed in an internal build, please disregard this comment.

Note You need to log in before you can comment on or make changes to this bug.