Bug 115082 - GtkCombo vs GTK_DISABLE_DEPRECATED=1
GtkCombo vs GTK_DISABLE_DEPRECATED=1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-spell (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 115187 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-06 06:37 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-11 17:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-02-06 06:37:37 EST
gtk/gtkcombo.h appears not to be in the standard include path.
gtk-2.0/gtk/gtkcombo.h is, as well as
gtk-1.2/gtk/gtkcombo.h

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I/usr/include
-DGNOMEDATADIR=\"/usr/share\" -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DGLADE_DATADIR=\"/usr/share/gnome-spell-1.0.5\"
-DPLUGIN_DIR=\"/usr/lib/bonobo/plugin\" -DGTK_DISABLE_DEPRECATED=1
-DASPELL_DICT=\"/usr/lib/aspell\" -DORBIT2=1 -pthread
-I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0
-I/usr/include/libart-2.0 -I/usr/include/gconf/2
-I/usr/include/libbonoboui-2.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0
-I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0
-I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0
-I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/X11R6/include
-I/usr/include/libxml2 -I/usr/include/libglade-2.0 -O2 -g -pipe
-march=athlon -Wp,-MD,.deps/control.pp -c control.c  -fPIC -DPIC -o
.libs/control.lo
In file included from control.c:37:
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h:63: error: syntax
error before "GtkCombo"
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h:63: warning: no
semicolon at end of struct or union
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h:67: error: syntax
error before '}' token
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h:70: error: syntax
error before "GtkComboClass"
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h:70: warning: no
semicolon at end of struct or union
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h:78: error: syntax
error before '}' token
make[2]: *** [control.lo] Error 1
make[2]: Leaving directory
`/usr/src/redhat/BUILD/gnome-spell-1.0.5/gnome-spell'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gnome-spell-1.0.5'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.47229 (%build)
                                                                     
                                                       
                                                                     
                                                       
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.47229 (%build)
Comment 1 Ivan Gyurdiev 2004-02-08 04:42:13 EST
The bug is caused by:
GTK_DISABLE_DEPRECATED=1 in the compiler flags, which causes GtkCombo
in gtkcombo.h to be undefined (the entire header seems deprecated).
The gtk folder is obviously in the include path of the compiler, so I
was just being retarded in my earlier post. 



Comment 2 Jeremy Katz 2004-02-17 19:29:37 EST
Fixed for -4
Comment 3 Caolan McNamara 2004-05-03 14:53:38 EDT
*** Bug 115187 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.