Bug 115187 - GtkCombo vs GTK_DISABLE_DEPRECATED=1
GtkCombo vs GTK_DISABLE_DEPRECATED=1
Status: CLOSED DUPLICATE of bug 115082
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 04:46 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 04:54:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-02-08 04:46:36 EST
I had a problem with gnome-spell where GtkCombo was undefined because
of  -DGTK_DISABLE_DEPRECATED. This seems to be the case here too:

make[3]: Entering directory
`/usr/src/redhat/BUILD/gnumeric-1.2.1/src/dialogs'
gcc -DHAVE_CONFIG_H -I. -I. -I../..
-DGNOMELOCALEDIR=\""/usr/share/locale"\"                           
-DGNUMERIC_DATADIR=\""/usr/share/gnumeric/1.2.1-bonobo"\"            
               -I../..                                               
     -I../../src                                                     
-I../../src/tools                                          
-I../../src/cut-n-paste-code/foocanvas                          
-DORBIT2=1 -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libgsf-1
-I/usr/include/libxml2 -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/X11R6/include
-I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/libglade-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/libart-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0
-I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0
-I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0
-I/usr/include/libgnomeui-2.0 -I/usr/include/libbonoboui-2.0
-I/usr/include/libgnomeprint-2.2 -I/usr/include/libgnomeprintui-2.2 
-O2 -g -pipe -march=athlon -DG_DISABLE_DEPRECATED
-DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED
-DGDK_MULTIHEAD_SAFE -DGTK_DISABLE_DEPRECATED
-DGNOME_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED
-DLIBGLADE_DISABLE_DEPRECATED -Wall -Wmissing-prototypes 
-Wsign-compare -Wpointer-arith -Wnested-externs -Wchar-subscripts
-Wwrite-strings -D_POSIX_SOURCE -D__EXTENSIONS__ -D_BSD_SOURCE -c
dao-gui-utils.c
In file included from dao-gui-utils.c:33:
../../src/gui-util.h:42: error: syntax error before "GtkCombo"
dao-gui-utils.c: In function `dialog_tool_init_outputs':
dao-gui-utils.c:144: warning: implicit declaration of function
`gtk_option_menu_set_history'
dao-gui-utils.c:144: warning: implicit declaration of function
`GTK_OPTION_MENU'
dao-gui-utils.c: In function `parse_output':
dao-gui-utils.c:256: warning: implicit declaration of function
`gtk_option_menu_get_history'
make[3]: *** [dao-gui-utils.o] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/gnumeric-1.2.1/src/dialogs'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/gnumeric-1.2.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gnumeric-1.2.1'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.10785 (%build)
                                                                     
                                                       
                                                                     
                                                       
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.10785 (%build)
Comment 1 Caolan McNamara 2004-05-03 14:53:36 EDT
This is the same as #115082#, should be ok in fedora core 2 (certainly
compiles fine from .srpm in that version)

*** This bug has been marked as a duplicate of 115082 ***
Comment 2 Caolan McNamara 2004-07-29 04:54:06 EDT
Closing...

Note You need to log in before you can comment on or make changes to this bug.