Bug 1151741 - FTBFS on arm
Summary: FTBFS on arm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hadoop
Version: 21
Hardware: armhfp
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Rati
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2014-10-11 09:11 UTC by Dan Horák
Modified: 2015-04-27 08:39 UTC (History)
4 users (show)

Fixed In Version: avro-1.7.5-10.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 21:53:45 UTC


Attachments (Terms of Use)
fix build on ARM (2.26 KB, patch)
2014-10-11 09:11 UTC, Dan Horák
no flags Details | Diff

Description Dan Horák 2014-10-11 09:11:38 UTC
Created attachment 945928 [details]
fix build on ARM

hadoop build fails on ARM in Java detection in hadoop-common with

...
[INFO] 
[INFO] --- maven-antrun-plugin:1.7:run (make) @ hadoop-common ---
[INFO] Executing tasks
main:
     [exec] -- The C compiler identification is GNU 4.9.1
     [exec] -- The CXX compiler identification is GNU 4.9.1
     [exec] -- Check for working C compiler: /usr/bin/cc
     [exec] -- Check for working C compiler: /usr/bin/cc -- works
     [exec] -- Detecting C compiler ABI info
     [exec] -- Detecting C compiler ABI info - done
     [exec] -- Check for working CXX compiler: /usr/bin/c++
     [exec] -- Check for working CXX compiler: /usr/bin/c++ -- works
     [exec] -- Detecting CXX compiler ABI info
     [exec] -- Detecting CXX compiler ABI info - done
     [exec] Soft-float JVM detected
     [exec] -- Looking for exit
     [exec] -- Looking for exit - not found
     [exec] -- Configuring incomplete, errors occurred!
     [exec] See also "/builddir/build/BUILD/hadoop-common-9e2ef43a240fb0f603d8c384e501daec11524510/hadoop-common-project/hadoop-common/target/native/CMakeFiles/CMakeOutput.log".
     [exec] See also "/builddir/build/BUILD/hadoop-common-9e2ef43a240fb0f603d8c384e501daec11524510/hadoop-common-project/hadoop-common/target/native/CMakeFiles/CMakeError.log".
     [exec] CMake Error at JNIFlags.cmake:59 (message):
     [exec]   Soft-float dev libraries required (e.g.  'apt-get install libc6-dev-armel'
     [exec]   on Debian/Ubuntu)
     [exec] Call Stack (most recent call first):
     [exec]   CMakeLists.txt:24 (include)
     [exec] 
...

The Java detection in JNIFlags.cmake is wrong when hadoop is built in a distribution. The solution is to drop the special handling of ARM completely, see the attached patch. Resulting scratch build is http://koji.fedoraproject.org/koji/taskinfo?taskID=7820354

Version-Release number of selected component (if applicable):
hadoop-2.4.1-5.fc21

Comment 1 Peter Robinson 2015-04-21 21:53:45 UTC

*** This bug has been marked as a duplicate of bug 999971 ***

Comment 2 Fedora Update System 2015-04-22 13:05:54 UTC
avro-1.7.5-10.fc22, hive-0.12.0-6.fc22, parquet-1.5.0-5.fc22, accumulo-1.6.1-3.fc22, hadoop-2.4.1-8.fc22, hbase-0.98.3-4.fc22, oozie-4.0.1-4.fc22, glusterfs-hadoop-2.3.2-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hadoop-2.4.1-8.fc22,avro-1.7.5-10.fc22,hbase-0.98.3-4.fc22,hive-0.12.0-6.fc22,oozie-4.0.1-4.fc22,parquet-1.5.0-5.fc22,glusterfs-hadoop-2.3.2-5.fc22,accumulo-1.6.1-3.fc22

Comment 3 Fedora Update System 2015-04-27 08:39:59 UTC
avro-1.7.5-10.fc22, hive-0.12.0-6.fc22, parquet-1.5.0-5.fc22, accumulo-1.6.1-3.fc22, hadoop-2.4.1-8.fc22, hbase-0.98.3-4.fc22, oozie-4.0.1-4.fc22, glusterfs-hadoop-2.3.2-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.