Bug 999971 - hadoop fails to build on arm architecture
Summary: hadoop fails to build on arm architecture
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hadoop
Version: 22
Hardware: arm
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Rati
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker F-ExcludeArch-ARM 1003862 1076927 1117968
TreeView+ depends on / blocked
 
Reported: 2013-08-22 13:25 UTC by Robert Rati
Modified: 2015-04-27 08:39 UTC (History)
5 users (show)

Fixed In Version: avro-1.7.5-10.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-27 08:39:52 UTC


Attachments (Terms of Use)

Description Robert Rati 2013-08-22 13:25:13 UTC
Description of problem:
The hadoop native bits fail to compile on the arm architecture

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Marek Goldmann 2013-12-03 11:15:02 UTC
This issue currently makes avro (and as a result hibernate-search too) broken on ARM.

Comment 2 Jaroslav Reznik 2015-03-03 14:59:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 Peter Robinson 2015-04-21 21:53:45 UTC
*** Bug 1151741 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2015-04-22 12:59:46 UTC
hadoop-2.4.1-8.fc22,avro-1.7.5-10.fc22,hbase-0.98.3-4.fc22,hive-0.12.0-6.fc22,oozie-4.0.1-4.fc22,parquet-1.5.0-5.fc22,glusterfs-hadoop-2.3.2-5.fc22,accumulo-1.6.1-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hadoop-2.4.1-8.fc22,avro-1.7.5-10.fc22,hbase-0.98.3-4.fc22,hive-0.12.0-6.fc22,oozie-4.0.1-4.fc22,parquet-1.5.0-5.fc22,glusterfs-hadoop-2.3.2-5.fc22,accumulo-1.6.1-3.fc22

Comment 5 Fedora Update System 2015-04-23 16:07:57 UTC
Package avro-1.7.5-10.fc22, hive-0.12.0-6.fc22, parquet-1.5.0-5.fc22, accumulo-1.6.1-3.fc22, hadoop-2.4.1-8.fc22, hbase-0.98.3-4.fc22, oozie-4.0.1-4.fc22, glusterfs-hadoop-2.3.2-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing avro-1.7.5-10.fc22 hive-0.12.0-6.fc22 parquet-1.5.0-5.fc22 accumulo-1.6.1-3.fc22 hadoop-2.4.1-8.fc22 hbase-0.98.3-4.fc22 oozie-4.0.1-4.fc22 glusterfs-hadoop-2.3.2-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6722/hadoop-2.4.1-8.fc22,avro-1.7.5-10.fc22,hbase-0.98.3-4.fc22,hive-0.12.0-6.fc22,oozie-4.0.1-4.fc22,parquet-1.5.0-5.fc22,glusterfs-hadoop-2.3.2-5.fc22,accumulo-1.6.1-3.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-27 08:39:52 UTC
avro-1.7.5-10.fc22, hive-0.12.0-6.fc22, parquet-1.5.0-5.fc22, accumulo-1.6.1-3.fc22, hadoop-2.4.1-8.fc22, hbase-0.98.3-4.fc22, oozie-4.0.1-4.fc22, glusterfs-hadoop-2.3.2-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.