Bug 1151854 - --cacheonly is not being respected – will update the cache if expired
--cacheonly is not being respected – will update the cache if expired
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-12 12:17 EDT by Christian Stadelmann
Modified: 2014-12-13 04:53 EST (History)
7 users (show)

See Also:
Fixed In Version: dnf-0.6.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-13 04:53:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2014-10-12 12:17:08 EDT
Description of problem:
I run `$ dnf --cacheonly upgrade` quite frequently. Every time the cache expires it updates the cache from network. This is not what the man page says:

-C, --cacheonly
Run  entirely  from  system cache, don't update the cache and use it even in case it is expired.
DNF uses a separate cache for each user under which it executes. The cache  for  the  root  user  is called the system cache. This switch allows a regular user read-only access to  the  system  cache  which usually  is  more fresh then the user's and thus he does not have to wait for metadata sync.


Version-Release number of selected component (if applicable):
dnf 0.6.2-1.fc21 from F21 Alpha

How reproducible:
always

Additional Info:
There was a similar bug: https://bugzilla.redhat.com/show_bug.cgi?id=1048468 so this seems to be a regression.
Comment 1 Michal Luscon 2014-10-20 08:06:00 EDT
Unfortunately, I am not able to reproduce this bug in dnf 0.6.2-1. Is there any difference between your system and fresh F21 alpha installation?
Comment 2 Christian Stadelmann 2014-10-26 06:45:38 EDT
Yes. I have set root's umask to 077 and have installed all available updates.
Comment 3 Fedora Update System 2014-12-09 09:06:44 EST
dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
Comment 4 Fedora Update System 2014-12-11 23:32:50 EST
Package dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.3-2.fc21 hawkey-0.5.2-1.fc21 dnf-plugins-core-0.1.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16760/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-12-13 04:53:51 EST
dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.