Bug 115186 - [RFE] bugzilla itself in fedora, why not ?
[RFE] bugzilla itself in fedora, why not ?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://bugzilla.redhat.com/download/b...
: FutureFeature
: 128959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 04:34 EST by shrek-m
Modified: 2014-03-16 22:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 15:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2004-02-08 04:34:09 EST
Description of problem:

i am missing bugzilla itself in fedora.
with all the different hardware/os/applications/users/admins/... in
 our environment @ work
 and my environment @home
bugzilla could be a solution to keep the overview of the problems and
their solutions.
i hope that you can understand what i mean with buggy users and buggy
admins :-)

in short words:
it would be nice if bugzilla itself would be in future releases


Version-Release number of selected component (if applicable):
$ ls
bugzilla-2.16.4.tar.gz  bugzilla-redhat-20031120.tar.gz

How reproducible:
always

Steps to Reproduce:
1. search bugzilla itself in fedora
  
Actual results:
nothing found


Expected results:
should be in fedora

Additional info:
https://bugzilla.redhat.com/bugzilla/index.cgi
http://www.bugzilla.org/
Comment 1 Bart Martens 2004-02-08 04:54:17 EST
Good idea.

I assume the license is not a problem, since Mozilla has the same
license. (I'm not an expert on licenses.)
http://www.bugzilla.org/download.html#howtoget
http://www.mozilla.org/MPL/

You chose component "httpd". Isn't "distribution" the general
component for requesting additional software to be included in fc1? If
that is correct, then I suggest you change the component to
"distribution".

Do you prefer the original bugzilla version, using mysql, or the
version modified by redhat to use postgresql?
Comment 2 shrek-m 2004-02-08 05:32:58 EST
http -> distribution  by  jorton@redhat.com
thanks.

what about:
redhat-version with additional support for mysql,
but i bet that redhat prefers for several reasons (eg. license) psql.
Comment 3 Bill Nottingham 2004-02-08 19:55:12 EST
Bugzilla really does sound like an 'Extras' sort of package, not part
of the core os.
Comment 4 Bart Martens 2004-02-09 00:28:26 EST
For who's wondering what Red Hat means by "Extras":
http://fedora.redhat.com/participate/terminology.html
Comment 5 Bart Martens 2004-02-20 01:25:27 EST
http://www.bugzilla.org/docs216/html/stepbystep.html
I think there is more to package than just Bugzilla itself. Some
needed packages are already in Core, like perl-DBD-MySQL (or
perl-DBD-Pg) and perl-DBI. Should all the other packages go in Extras,
or should some of them go in Core? Maybe some of these packages are
already packaged elsewhere, and can easily be moved/copied to Extras
or Core?
Comment 6 Miloslav Trmač 2004-08-02 13:49:18 EDT
*** Bug 128959 has been marked as a duplicate of this bug. ***
Comment 7 Robert Scheck 2004-08-02 13:53:31 EDT
I personally can't see a real need for a bugzilla package in Fedora 
Core/Extras/... but I'm curious what's going on, now...
Comment 8 Bill Nottingham 2004-08-02 15:31:10 EDT
Closing as WONTFIX for now, on the supposition that it's better for
Extras.

Note You need to log in before you can comment on or make changes to this bug.