Bug 1152339 - Staypuft Network Configuration: Operation FAILED: uninitialized constant Net::Validations::MASK_REGEXP
Summary: Staypuft Network Configuration: Operation FAILED: uninitialized constant Net:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1152612 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-14 00:35 UTC by wes hayutin
Modified: 2014-11-04 17:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (162.94 KB, image/png)
2014-10-14 00:35 UTC, wes hayutin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description wes hayutin 2014-10-14 00:35:48 UTC
Created attachment 946633 [details]
screenshot

Description of problem:

Operation FAILED: uninitialized constant Net::Validations::MASK_REGEXP

Recreate:
1. create a new deployment
2. fill out initial deployment settings; next ->
3. On network window, create new subnet -> fill it out -> submit

Started POST "/staypuft/subnets?deployment_id=2" for 10.10.60.32 at 2014-10-13 20:31:05 -0400
Processing by Staypuft::SubnetsController#create as JS
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"VwPx60d3TU6/d7rFUAiCVJhHfZkvSFkp1z9fGMdMqdo=", "staypuft_simple_subnet"=>{"name"=>"external", "dhcp_server"=>"external", "network_address"=>"192.168.122.0/24", "vlan"=>"", "gateway"=>"", "ip_range_from"=>"", "ip_range_to"=>""}, "commit"=>"Create Subnet", "deployment_id"=>"2"}
Operation FAILED: uninitialized constant Net::Validations::MASK_REGEXP
  Rendered common/500.html.erb (3.6ms)
Completed 500 Internal Server Error in 14ms (Views: 4.0ms | ActiveRecord: 0.7ms)

Comment 1 wes hayutin 2014-10-14 00:38:13 UTC
recreate on firefox or chrome

ruby193-rubygem-apipie-params-0.0.3-2.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.9-1.1.el6sat.noarch
ruby193-rubygem-open4-1.3.0-9.el6sat.noarch
rubygem-thor-0.14.6-5.el6sat.noarch
rubygem-ffi-1.4.0-3.el6sat.x86_64
ruby193-rubygem-pg-0.12.2-10.el6sat.x86_64
ruby193-rubygem-passenger-native-4.0.18-19.el6sat.x86_64
rubygem-hammer_cli-0.1.1-12.el6sat.noarch
rubygem-highline-1.6.21-1.el6sat.noarch
rubygem-multi_json-1.8.2-4.el6sat.noarch
rubygem-ansi-1.4.3-3.el6sat.noarch
rubygem-fastercsv-1.5.4-10.el6sat.noarch
rubygem-kafo-0.6.4-1.el6ost.noarch
ruby193-rubygem-bigdecimal-1.1.0-49.el6.x86_64
ruby193-rubygem-rack-1.4.1-5.el6.noarch
ruby193-rubygem-multi_json-1.3.6-2.el6.noarch
ruby193-rubygem-json-1.5.5-49.el6.x86_64
ruby193-rubygem-mime-types-1.19-1.el6.noarch
ruby193-rubygem-i18n_data-0.2.7-5.el6sat.noarch
ruby193-rubygem-rack-cache-1.2-2.el6.noarch
ruby193-rubygem-nokogiri-1.5.11-1.el6sat.x86_64
ruby193-rubygem-sass-3.2.13-1.el6sat.noarch
ruby193-rubygem-audited-3.0.0-5.el6sat.noarch
ruby193-rubygem-mysql2-0.3.11-4.el6sat.x86_64
ruby193-rubygem-bundler_ext-0.3.0-6.el6sat.noarch
ruby193-rubygem-mail-2.4.4-4.el6.noarch
ruby193-rubygem-actionpack-3.2.8-13.el6.noarch
ruby193-rubygem-actionmailer-3.2.8-1.el6.noarch
ruby193-rubygem-therubyracer-0.11.0-0.9.beta5.el6.x86_64
ruby193-rubygem-deface-0.7.2-7.el6sat.noarch
ruby193-rubygem-validates_lengths_from_database-0.2.0-1.3.el6sat.noarch
ruby193-rubygem-will_paginate-3.0.2-10.el6sat.noarch
rubygem-json-1.4.6-10.el6.x86_64
rubygem-oauth-0.4.7-8.el6sat.noarch
rubygem-rest-client-1.6.7-1.el6sat.noarch
rubygem-foreman_api-0.1.11-6.el6sat.noarch
rubygem-clamp-0.6.2-2.el6sat.noarch
rubygem-rgen-0.6.6-2.el6.noarch
rubygem-logging-1.8.1-26.el6sat.noarch
rubygem-awesome_print-1.0.2-12.el6sat.noarch
rubygem-powerbar-1.0.11-8.el6sat.noarch
rubygem-apipie-bindings-0.0.8-1.el6sat.noarch
rubygem-kafo_parsers-0.0.3-2.el6sat.noarch
ruby193-rubygem-io-console-0.3-49.el6.x86_64
ruby193-rubygems-1.8.23-49.el6.noarch
ruby193-rubygem-sexp_processor-4.1.3-7.el6sat.noarch
ruby193-rubygem-rake-0.9.2.2-49.el6.noarch
ruby193-rubygem-fast_gettext-0.8.0-13.el6sat.noarch
ruby193-rubygem-builder-3.0.0-3.el6.noarch
ruby193-rubygem-i18n-0.6.0-3.el6.noarch
ruby193-rubygem-activemodel-3.2.8-2.el6.noarch
ruby193-rubygem-rest-client-1.6.7-1.el6sat.noarch
ruby193-rubygem-rabl-0.9.0-1.el6sat.noarch
ruby193-rubygem-po_to_json-0.0.7-3.el6sat.noarch
ruby193-rubygem-ftools-0.0.0-5.el6sat.noarch
ruby193-rubygem-algebrick-0.4.0-3.el6sat.noarch
ruby193-rubygem-dynflow-0.7.3-1.el6sat.noarch
ruby193-rubygem-sinatra-1.3.2-12.el6.noarch
ruby193-rubygem-ipaddress-0.8.0-6.el6ost.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.2.el6ost.noarch
ruby193-rubygem-staypuft-0.4.4-1.el6ost.noarch
rubygem-rack-1.4.1-13.el6sat.noarch
rubygem-rkerberos-0.1.2-3.el6sat.x86_64
rubygem-bundler-1.0.15-5.el6sat.noarch
rubygem-rake-0.9.2.2-41.el6sat.noarch
rubygem-rubyipmi-0.7.0-2.el6sat.noarch
rubygem-sinatra-1.3.6-27.el6sat.noarch
rubygem-gssapi-1.1.2-4.el6sat.noarch
rubygem-passenger-4.0.18-19.el6sat.x86_64
rubygem-passenger-native-4.0.18-19.el6sat.x86_64
ruby193-rubygem-passenger-native-libs-4.0.18-19.el6sat.x86_64
rubygem-fast_gettext-0.8.0-13.el6sat.noarch
rubygem-table_print-1.5.1-3.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.1-16.el6sat.noarch
ruby193-rubygem-safemode-1.2.1-1.el6sat.noarch
ruby193-rubygem-rack-ssl-1.3.2-7.el6.noarch
ruby193-rubygem-oauth-0.4.7-8.el6sat.noarch
ruby193-rubygem-daemons-1.1.4-10.el6sat.noarch
ruby193-rubygem-uuidtools-2.1.3-6.el6sat.noarch
ruby193-rubygem-bootstrap-sass-3.0.3.0-1.el6sat.noarch
ruby193-rubygem-thin-1.3.1-9.el6sat.x86_64
ruby193-rubygem-hike-1.2.1-3.el6.noarch
ruby193-rubygem-tzinfo-0.3.33-2.el6.noarch
ruby193-rubygem-diff-lcs-1.1.3-1.el6.noarch
ruby193-rubygem-bundler-1.3.5-1.el6.noarch
ruby193-rubygem-journey-1.0.4-2.el6.noarch
ruby193-rubygem-treetop-1.4.10-6.el6.noarch
ruby193-rubygem-tilt-1.3.3-10.el6.noarch
ruby193-rubygem-erubis-2.7.0-4.el6.noarch
ruby193-rubygem-railties-3.2.8-3.el6.noarch
ruby193-rubygem-jquery-ui-rails-4.0.2-8.el6sat.noarch
ruby193-rubygem-minitest-2.5.1-49.el6.noarch
ruby193-rubygem-ref-1.0.0-3.el6.noarch
ruby193-rubygem-arel-3.0.2-3.el6.noarch
ruby193-rubygem-rails-3.2.8-2.el6.noarch
ruby193-rubygem-gettext_i18n_rails_js-0.0.8-3.el6sat.noarch
ruby193-rubygem-foreigner-1.4.2-1.el6sat.noarch
ruby193-rubygem-scoped_search-2.7.1-2.el6sat.noarch
ruby193-rubygem-deep_cloneable-1.6.0-3.el6sat.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
ruby193-rubygem-sequel-3.45.0-6.el6sat.noarch
ruby193-rubygem-rack-protection-1.2.0-7.el6.noarch
ruby193-rubygem-wicked-1.0.2-2.el6ost.noarch
rubygem-rack-protection-1.5.0-7.el6sat.noarch
rubygem-bundler_ext-0.3.0-7.el6sat.noarch
rubygem-tilt-1.3.3-18.el6sat.noarch
rubygem-passenger-native-libs-4.0.18-19.el6sat.x86_64
ruby193-rubygem-passenger-4.0.18-19.el6sat.x86_64
rubygem-locale-2.0.9-7.el6sat.noarch
rubygems-1.8.16-1.el6.noarch
rubygem-mime-types-1.19-7.el6sat.noarch
rubygem-rdoc-3.12-27.el6sat.x86_64
rubygem-little-plugger-1.1.3-17.el6sat.noarch
rubygem-hashie-2.0.5-2.el6sat.noarch
ruby193-rubygem-rdoc-3.9.5-49.el6.x86_64
ruby193-rubygem-ruby_parser-3.1.1-15.el6sat.noarch
ruby193-rubygem-gettext_i18n_rails-0.10.0-3.el6sat.noarch
ruby193-rubygem-activesupport-3.2.8-5.el6.noarch
ruby193-rubygem-activeresource-3.2.8-2.el6.noarch
ruby193-rubygem-ruby2ruby-2.0.1-9.el6sat.noarch
ruby193-rubygem-rack-test-0.6.1-3.el6.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
ruby193-rubygem-eventmachine-0.12.10-11.el6sat.x86_64
ruby193-rubygem-net-http-persistent-2.7-3.el6.noarch
ruby193-rubygem-thor-0.18.1-2.el6.noarch
ruby193-rubygem-polyglot-0.3.3-2.el6.noarch
ruby193-rubygem-sprockets-2.10.1-3.el6sat.noarch
ruby193-rubygem-jquery-rails-2.0.2-2.el6.noarch
ruby193-rubygem-apipie-rails-0.2.5-1.el6sat.noarch
ruby193-rubygem-activerecord-3.2.8-16.el6sat.noarch
ruby193-rubygem-ancestry-2.0.0-1.el6sat.noarch
ruby193-rubygem-audited-activerecord-3.0.0-8.el6sat.noarch

Comment 5 Mike Burns 2014-10-14 14:17:32 UTC
*** Bug 1152612 has been marked as a duplicate of this bug. ***

Comment 6 Scott Seago 2014-10-14 16:31:55 UTC
This seems to be a foreman version issue. Net::Validations::MASK_REGEXP was recently added upstream (committed Sept 12 2014), so it's probably not pulled into the build we're using.

Comment 7 Mike Burns 2014-10-14 16:34:04 UTC
A required patch backport from upstream was missing:  

https://github.com/theforeman/foreman/commit/7af45f09

Comment 9 Alexander Chuzhoy 2014-10-15 14:34:03 UTC
Verified:
foreman-1.6.0.44-5.el6ost.noarch
rhel-osp-installer-0.4.3-1.el6ost.noarch


The reported issue doesn't reproduce. Able to create subnets.

Comment 12 Mike Burns 2014-10-24 13:39:48 UTC
internal only bug

Comment 14 errata-xmlrpc 2014-11-04 17:03:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.