Bug 115293 - Assign categories form has errors on IE
Assign categories form has errors on IE
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
Jon Orris
:
: 116462 (view as bug list)
Depends On:
Blocks: 113496
  Show dependency treegraph
 
Reported: 2004-02-10 06:11 EST by Daniel Berrange
Modified: 2007-04-18 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 15:58:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2004-02-10 06:11:10 EST
Description of problem:
When initially displaying the 'add categories' form in the categories
authoring kit step, Internet Explorer shows a bunch of JavaScript
errors, but oddly continues to work normally.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create an article
2. Go to assign categories
3. Select 'Add categories'
  
Actual results:
Javascript errors

Expected results:
No errors

Additional info:
Comment 1 Richard Li 2004-02-10 07:08:27 EST
Which version of IE?
Comment 2 Daniel Berrange 2004-02-10 07:10:22 EST
I've seen it on 6.0, and we've had 3rd party report of 5.5 too
Comment 3 Scott Seago 2004-02-11 17:38:13 EST
Hmm. I'm not seeing any javascript errors with IE 6.0. Are you getting
the error consistently?
Comment 4 Scott Seago 2004-02-19 18:27:25 EST
The problem occurs when a category has the "'" character in its name.

Replace ' with \' in category fullname (since it's used in a
javascript function call)

Fixed @40606.
Comment 5 Daniel Berrange 2004-02-23 06:45:05 EST
*** Bug 116462 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.