Bug 1152951 - Impossible to set up an IPv6 multipath route
Summary: Impossible to set up an IPv6 multipath route
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute
Version: 6.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On: 1201208
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-15 09:22 UTC by ddu
Modified: 2019-07-11 08:16 UTC (History)
4 users (show)

Fixed In Version: iproute-2.6.32-43.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, multipath routing did not function with IPv6 addresses and resulted in an "IP address is expected rather than "2001:470:25:94::1" error. To fix this bug, a patch that enables adding multipath routes using IPv6 addresses has been applied.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:41:01 UTC


Attachments (Terms of Use)
patch (728 bytes, patch)
2014-12-16 10:12 UTC, Pavel Šimerda (pavlix)
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1331 normal SHIPPED_LIVE iproute bug fix and enhancement update 2015-07-20 17:53:02 UTC

Description ddu 2014-10-15 09:22:31 UTC
Description of problem:

This is the same bug as in Fedora:
https://bugzilla.redhat.com/show_bug.cgi?id=734697

In Fedora, this bug has been fixed.

Also in Debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556974

Doing multipath routing with IPv4 works fine, but it doesn't with IPv6:
    # ip -6 route add default nexthop via 2001:470:25:94::1 weight 1 nexthop via 2001:41e0:ff00:47::1 weight 1
    Error: an IP address is expected rather than "2001:470:25:94::1"

Note that the Debian bug doesn't specify it, but the problem happens even if you only specify one path:
    # ip -6 route add default nexthop via 2001:470:25:94::1 weight 1

This should be equivalent to the same command without the "nexthop":
    # ip -6 route add default via 2001:470:25:94::1 weight 1
    Error: an IP address is expected rather than "2001:470:25:94::1"

Again, this works perfectly fine with IPv4.

How reproducible:
    100%

Steps to Reproduce:
    1. Make sure your network is IPv6 enabled
    2. Try adding a multipath IPv6 route (it doesn't have to have several "nexthop", one is enough to trigger the bug)

Actual results:
Below error output:
Error: an IP address is expected rather than "2001:470:25:94::1"

Expected results:
A working IPv6 multipath route.

Comment 3 Pavel Šimerda (pavlix) 2014-12-16 10:12:03 UTC
Created attachment 969509 [details]
patch

Comment 16 Jaroslav Aster 2015-03-09 10:39:52 UTC
Still does not work. Same error message.

Comment 20 errata-xmlrpc 2015-07-22 06:41:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1331.html


Note You need to log in before you can comment on or make changes to this bug.